MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Modules suspending and never resuming after HotWord and MK2



  • I am using a Sony PS Eye for my mic. I recently installed Hotword and MK2. All modules disappear after some time besides currentWeather. I looked through the console from chromium and found this:

    AssistantMk2 / HotWord
    module.js:154 calendar received a module notification: HOTWORD_PAUSE from sender: MMM-AssistantMk2
    module.js:154 MMM-NetworkScanner received a module notification: HOTWORD_PAUSE from sender: MMM-AssistantMk2
    module.js:205 alert is resumed.
    module.js:205 updatenotification is resumed.
    main.js:275 Will not show updatenotification. LockStrings active: module_4_MMM-iFrame-Ping
    module.js:205 clock is resumed.
    module.js:205 calendar is resumed.
    module.js:205 currentweather is resumed.
    module.js:205 MMM-NetworkScanner is resumed.
    module.js:205 mmm-nest-status is resumed.
    module.js:205 MMM-Hotword is resumed.
    module.js:205 MMM-AssistantMk2 is resumed.
    module.js:154 clock received a module notification: HOTWORD_LISTENING from sender: MMM-Hotword
    
    Then some time more later
    
    alert is suspended.
    module.js:198 MMM-Hotword is suspended.
    module.js:198 updatenotification is suspended.
    module.js:198 clock is suspended.
    module.js:198 calendar is suspended.
    module.js:198 currentweather is suspended.
    module.js:198 MMM-NetworkScanner is suspended.
    module.js:198 mmm-nest-status is suspended.
    module.js:198 MMM-AssistantMk2 is suspended.
    

    CurrentWeather eventually resumes and remains the only module. If I call HotWord and give it a command all the modules resume.

    Full Log from the console can be seen here:

    https://pastebin.com/xCw9J4W2

    My Module Config:

    //Hotword Module
    {
        module: "MMM-Hotword",
        config: {
          record: {
            recordProgram : "arecord",  
            device        : "plughw:1",
          },
          autostart:true,
          onDetected: {
            notification: function (payload) {
              return "ASSISTANT_ACTIVATE"
            },
            payload: function (payload){
              return {
                profile: payload.hotword
              }
            }
          },
        },
      },
    
    //Google Assistant 2
    {
    		module: "MMM-AssistantMk2",
    		position: "bottom_bar",
    		config: {
    		record: {
            recordProgram : "arecord",  
            device        : "plughw:1",
          },
    	screenDuration: 5000,
          notifications: {
            ASSISTANT_ACTIVATED: "HOTWORD_PAUSE",
            ASSISTANT_DEACTIVATED: "HOTWORD_RESUME",
          },
    deviceLocation: {
          coordinates: { // set the latitude and longitude of the device to get localized information like weather or time. (ref. mygeoposition.com)
            latitude: 00.8, // -90.0 - +90.0
            longitude: -00.667821, // -180.0 - +180.0
          },
        },
                    
    }
    },
    

    Any insight would be helpful.
    MagicMirror 2 v 2.6.0
    All Modules Updated


  • Module Developer

    @numb3rs
    It might be due to “onIdle” and “onDetected” features. Disable them.(see the manual)


Log in to reply