MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Hotword, x86 and invalid pointer



  • Hi all,

    I’ve installed Debian Stretch on my laptop, and tried to run MMM-Hotword.
    Installation is successful without errors, but when trying to run ‘npm start’, I get an error:

    ../../third_party/tcmalloc/chromium/src/tcmalloc.cc:289] Attempt to free invalid pointer 0x7ffeaef7b090
    

    I’ve asked the developer, and he assumes it is snowboy that causes the issue, as snowboy git states:

    Currently Snowboy supports (look into the lib folder):
    
    all versions of Raspberry Pi (with Raspbian based on Debian Jessie 8.0)
    64bit Mac OS X
    64bit Ubuntu 14.04
    iOS
    Android
    ARM64 (aarch64, Ubuntu 16.04)
    

    My questions is; what platforms, types of linux and versions have you guys been able to run Hotword on?


  • Module Developer

    @thestigh
    Usually, MM is executed on Raspberry Pi.(Raspbian Stretch). It is based on Debian Stretch but ARM based.
    For other unsupported platform, you cannot use Hotword detector based Snowboy. But there might be alternatives.

    • PocketSphinx
    • Google Speech API
    • PicoVoice
      and so more.
      Some are already implemented to MM modules, or you can make your own for your platform if you have some experiences for programming.


  • Hi @sean
    Thanks for your prompt reply, really appreciate it 🙂

    My ‘issue’ is trying to put a lot of info on my MM, including video streams which makes the RPi to slow. So I’m searching for other ways of getting more power = miniPC etc running a linux variant compatible with Hotword and AssistantMk2.

    I can see that Ubuntu 14.04 are supported on 64 bit, but was hoping there are something ‘newer’ available which has been achieved by geniuses like you.

    My developer skills are not good, though I can read and quite understand .js


  • Module Developer

    @thestigh
    I think this could be one of alternatives;

    It has features simple voice commands in itself. You can use this standalone or Waker for MMM-AssistantMk2 (I haven’t tried but I have a will to help you)


Log in to reply