MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

after update and upgrade raspberry and magic mirror



  • Hi,
    Thanks to help me this is the message when i try to start with “npm start”

    pi@raspberrypi:~/MagicMirror $ npm start
    (node:5115) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.

    magicmirror@2.6.0 start /home/pi/.local/share/Trash/files/MagicMirror.2
    sh run-start.sh

    run-start.sh: 4: run-start.sh: electron: not found

    npm ERR! magicmirror@2.6.0 start: sh run-start.sh
    npm ERR! Exit status 127
    npm ERR!
    npm ERR! Failed at the magicmirror@2.6.0 start script.
    npm ERR! This is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! sh run-start.sh
    npm ERR! You can get their info via:
    npm ERR! npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    npm ERR! System Linux 4.14.79-v7+
    npm ERR! command “/usr/bin/node” “/usr/bin/npm” “start”
    npm ERR! cwd /home/pi/.local/share/Trash/files/MagicMirror.2
    npm ERR! node -v v8.11.1
    npm ERR! npm -v 1.4.21
    npm ERR! code ELIFECYCLE
    npm WARN This failure might be due to the use of legacy binary “node”
    npm WARN For further explanations, please read
    /usr/share/doc/nodejs/README.Debian

    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR! /home/pi/.local/share/Trash/files/MagicMirror.2/npm-debug.log
    npm ERR! not ok code 0
    pi@raspberrypi:~/MagicMirror $



  • can u show us the output of

    npm -v
    

    and

    node -v
    


  • @sdetweil thanks

    pi@raspberrypi:~/MagicMirror $ npm -v
    1.4.21
    (node:5164) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.

    and

    pi@raspberrypi:~/MagicMirror $ node -v
    v8.11.1



  • @fonfon said in after update and upgrade raspberry and magic mirror:

    pi@raspberrypi:~/MagicMirror $ npm -v
    1.4.21

    that is very old… please upgrade,

    i have 2 systems, 1 is at 3.5.2 (still too old, thx will upgrade)
    and 6.1.0

    use

    curl -L https://npmjs.org/install.sh | sudo sh
    


  • @sdetweil thanks your command works great for upgrade !
    but after i have the same problem

    pi@raspberrypi:~ $ npm -v
    6.6.0
    pi@raspberrypi:~ $ cd MagicMirror/
    pi@raspberrypi:~/MagicMirror $ npm start

    magicmirror@2.6.0 start /home/pi/MagicMirror
    sh run-start.sh

    run-start.sh: 4: run-start.sh: electron: not found
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.6.0 start: sh run-start.sh
    npm ERR! spawn ENOENT
    npm ERR!
    npm ERR! Failed at the magicmirror@2.6.0 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/pi/.npm/_logs/2019-01-20T16_40_06_112Z-debug.log
    pi@raspberrypi:~/MagicMirror $



  • @fonfon in the magic mirror folder

    npm -i electron
    


  • @sdetweil command don’t work



  • @fonfon please add more info



  • @sdetweil for sure sorry

    pi@raspberrypi:~/MagicMirror $ npm -i electron

    Usage: npm

    where is one of:
    access, adduser, audit, bin, bugs, c, cache, ci, cit,
    clean-install, clean-install-test, completion, config,
    create, ddp, dedupe, deprecate, dist-tag, docs, doctor,
    edit, explore, get, help, help-search, hook, i, init,
    install, install-ci-test, install-test, it, link, list, ln,
    login, logout, ls, org, outdated, owner, pack, ping, prefix,
    profile, prune, publish, rb, rebuild, repo, restart, root,
    run, run-script, s, se, search, set, shrinkwrap, star,
    stars, start, stop, t, team, test, token, tst, un,
    uninstall, unpublish, unstar, up, update, v, version, view,
    whoami

    npm -h quick help on
    npm -l display full usage info
    npm help search for help on
    npm help npm involved overview

    Specify configs in the ini-formatted file:
    /home/pi/.npmrc
    or on the command line via: npm --key value
    Config info can be viewed via: npm help config

    npm@6.6.0 /usr/lib/node_modules/npm

    pi@raspberrypi:~/MagicMirror $



  • @fonfon ok, my mistake

    npm i electron
    

    no dash (-)


Log in to reply