MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

Black screen after reboot.



  • Restarted the pi today and i added a different city to the current weather and weather forecasts. Something ive done before with no issue. ran the mirror again and got a black screen. after clicking about i found the bellow text at the top of the screen. I went back and changed the file config back to no change.

    @font-face { font-family: Roboto; font-style: normal; font-weight: 100; src: local(“Roboto Thin”), local(“Roboto-Thin”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Thin.woff2”) format(“woff2”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Thin.woff”) format(“woff”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Thin.ttf”) format(“truetype”); } @font-face { font-family: “Roboto Condensed”; font-style: normal; font-weight: 300; src: local(“Roboto Condensed Light”), local(“RobotoCondensed-Light”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Light.woff2”) format(“woff2”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Light.woff”) format(“woff”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Light.ttf”) format(“truetype”); } @font-face { font-family: “Roboto Condensed”; font-style: normal; font-weight: 400; src: local(“Roboto Condensed”), local(“RobotoCondensed-Regular”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Regular.woff2”) format(“woff2”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Regular.woff”) format(“woff”),url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Regular.ttf”) format(“truetype”); } @font-face { font-family: “Roboto Condensed”; font-style: normal; font-weight: 700; src: local(“Roboto Condensed Bold”), local(“RobotoCondensed-Bold”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Bold.woff2”) format(“woff2”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Bold.woff”) format(“woff”), url(“node_modules/roboto-fontface/fonts/roboto-condensed/Roboto-Condensed-Bold.ttf”) format(“truetype”); } @font-face { font-family: Roboto; font-style: normal; font-weight: 400; src: local(“Roboto”), local(“Roboto-Regular”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Regular.woff2”) format(“woff2”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Regular.woff”) format(“woff”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Regular.ttf”) format(“truetype”); } @font-face { font-family: Roboto; font-style: normal; font-weight: 500; src: local(“Roboto Medium”), local(“Roboto-Medium”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Medium.woff2”) format(“woff2”), url(“node_modules/roboto-fontface/fonts/roboto/Roboto-Medium.woff”) format(“woff”), url("node_modules/roboto-fontface/fonts/rob

    thanks for any help, just started messing with the rasp pi and the mirror at the start of the month, so i know little to nothing0_1556128140850_2019-04-24-124123_1920x1080_scrot.png



  • open the developers window, with ctrl-shift-i keystrokes,
    then using mouse select the console tab, and then scroll up to find any errors (red text)

    please advise



  • @sdetweil It looks like the only error is a security warning " this renderer process has either no content security policy set or a policy with “unsafe-eval” enabled. this exposes users of this app to unnecessary risks

    /home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/renderer/security-warnings.js:184



  • even i am facing a similar issue.
    i can not operate developers window also.
    can anyone suggest something and help me resolve this issue?
    Thank you in advance.


  • Project Sponsor

    The OP message appears to be confined to the fonts of the mirror. At least, I don’t see anything else in there.

    First, when posting error messages, please use the markdown features of the board. It helps with readability.

    Second, I would try reinstalling the fonts for the mirror. I think this is how to do it without having to reinstall the entire mirror framework:

    cd ~/MagicMirror/fonts
    npm install
    

    With luck, it will regenerate your fonts folder and fix whatever this error is.



  • @bhepler said in Black screen after reboot.:

    will regenerate your fonts folder and fix whatever this error is

    I tried a reinstall of fonts. But there was no change. Could there be another file somewhere what would reference the fonts for whatever reason that may be printing it to the screen?

    PS this is what i see when i start the mirror, guess i should have included this earlier

    0_1556128054427_2019-04-24-124123_1920x1080_scrot.png



  • I believe this actually may have begun with the new update about a month ago so I may try reinstalling a fresh build.