MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Vertical Display Graphical Errors



  • Hi all,

    I’m new to the forum, new to the rapberry pi, and could use some help.

    I’m building a MagicMirror, or at least I’m using MagicMirror as a starting point for different projects.

    Everything has been going well for the most part. I used NOOBS to get set up but only installed Raspbian Stretch (I suspect this may be a part of the issue). I installed MagicMirror. Then, I rotated the display to vertical in /boot/config.txt and while it worked, now the screen is acting pretty oddly.

    The display seems to have been divided by 2 near invisible diagonal lines. They make the display look in essence like 2 or 3 parallelograms fashioning a single image rather than a single rectangle fashioning a single image.

    It only is noticeable when an image is moving but that’s pretty undesirable as I’d like to be able to view video or image slideshows on it without it looking glitchy.

    I’ve tried some different solutions but to no avail.

    Things I’ve tried:

    • set the gpu memory split to 256 both in /boot/config.txt and raspi-config

    • changed the GL driver. When I switch to either Full or Fake kms and reboot, the screen is no longer vertical despite my /boot/config.txt telling it to display_rotate=1. Because it doesn’t actually go vertical in either full or fake KMS , there’s no way for me to know if it helps my issue. I’m only able to have a vertical display in Legacy.

    • alter /boot/config.txt in multiple ways I saw suggested online.

    I’m pretty stumped and haven’t seen much discussion of this online.

    Here’s a Youtube link to a video of my build for reference. When the slideshow transfers to the snow scene you can really see the divisions in the screen.

    https://youtu.be/ZzL0XMkV7hM

    Any help would be greatly appreciated.

    Thanks in advance



  • I’ve also tried installing just a clean raspbian stretch. However, the problem persists when I rotate the display with only the desktop environment of stretch running.

    I’m now thinking that the 32" Samsung I’m using may be the issue and I’m going to try out another make/model.


Log in to reply