MM on a secondary display



  • I have a Raspberry Pi Official 7" touch screen working as an extended desktop display in addition to my HDMI monitor. How can I have MM run (only) on the 7" touch screen instead of my HDMI monitor?

    It seems I should be able to write DISPLAY=1 or :1 (environment variable) somewhere and it should do the trick, but I haven’t found where.


  • Project Sponsor

    Hi, first of all, how is the 7" screen connected to the raspberry? is connected to the HDMI port? And your monitor? I think you can choose which monitor to use on /boot/config.txt file.

    Look here, maybe it helps: https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

    If your 7" screen is connected with a flat wire to the raspberry, and your monitor with HDMI, I think you can choose wich screen to use on the config.txt too.



  • Thanks for the reply. I just wanted MM shown on the secondary screen which is working already, going through the config.txt is useful if you need to get it to work or enable/disable it.

    I stepped away for a sec and realized that the default mode uses the touchscreen as an extended display. So I simply need to move the window using electronOptions in the config file (do’h!).