MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MagicMirror wont start after failed update



  • Hi,
    I have not worked with the MagicMirror for too long.
    I did an updaet a few days ago and had a power outage at that very moment ☔ . Although there are backup but unfortunately these are already a few months old 😖 .
    Since the power failure Magicmirror does not start anymore. I have again executed the command git pull && npm install without success.

    Here’s the npm log:

    0 info it worked with it ends with ok
    1 verbose cli [’/ usr / bin / node’, ‘/ usr / bin / npm’, ‘start’]
    2 info using npm@6.11.3
    3 info using node@v10.16.3
    4 verbose run-script [‘prestart’, ‘start’, ‘poststart’]
    5 info lifecycle magicmirror@2.9.0~prestart: magicmirror@2.9.0
    6 info lifecycle magicmirror@2.9.0~start: magicmirror@2.9.0
    7 verbose lifecycle magicmirror@2.9.0~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.9.0~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local / sbin: / usr / local / bin: / usr / sbin: / usr / bin: / sbin: / bin: / usr / local / games / usr / games
    9 verbose lifecycle magicmirror@2.9.0~start: CWD: / home / pi / MagicMirror
    10 silly lifecycle magicmirror@2.9.0~start: Args: [’-c’, ‘sh run-start.sh’]
    11 silly lifecycle magicmirror@2.9.0~start: Returned: code: 1 signal: zero
    12 info lifecycle magicmirror@2.9.0~start: Failed to exec start script
    13 verbose stack Error: magicmirror@2.9.0 start: sh run-start.sh
    13 verbose stack Exit status 1
    13 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
    13 verbose stack at EventEmitter.emit (events.js: 198: 13)
    13 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    13 verbose stack at ChildProcess.emit (events.js: 198: 13)
    13 verbose stack at maybeClose (internal / child_process.js: 982: 16)
    13 verbose stack at Process.ChildProcess._handle.onexit (internal / child_process.js: 259: 5)
    14 verbose pkgid magicmirror@2.9.0
    15 verbose cwd / home / pi / MagicMirror
    16 verbose Linux 4.19.66-v7 +
    17 verbose argv “/ usr / bin / node” “/ usr / bin / npm” “start”
    18 verbose node v10.16.3
    19 verbose npm v6.11.3
    20 error code ELIFECYCLE
    21 error errno 1
    22 error magicmirror@2.9.0 start: sh run-start.sh
    22 error Exit status 1
    23 error Failed at the magicmirror@2.9.0 start script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [1, true]

    I hope someone can help me.



  • @unknownuser26 always fun when the lights go out!

    do

    cd ~/MagicMirror
    rm -rf node_modules
    npm install
    

    that should get you back to working



  • Thanks alot. The Magic Mirror starts again.
    Unfortunately, I still get this message when I run npm install. Can you ignore the warnings? The instruction npm audit fix could not solve the problem either

    pi@magicmirror:~/MagicMirror $ npm install
    npm WARN deprecated time-grunt@2.0.0: Deprecated because Grunt is practically unmaintained. Move on to something better. This package will continue to work with Grunt v1, but it will not receive any updates.
    
    electron-chromedriver@1.8.0 install /home/pi/MagicMirror/node_modules/electron-chromedriver
     node ./download-chromedriver.js
    
    successfully dowloaded and extracted!
    
     electron@3.0.13 postinstall /home/pi/MagicMirror/node_modules/electron
     node install.js
    
    Downloading tmp-11791-1-SHASUMS256.txt-3.0.13
    [============================================>] 100.0% of 4.79 kB (4.79 kB/s)
    
    > magicmirror@2.9.0 install /home/pi/MagicMirror
    > cd vendor && npm install
    
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    
    audited 220 packages in 6.3s
    found 5 vulnerabilities (4 low, 1 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    
     magicmirror@2.9.0 postinstall /home/pi/MagicMirror
     sh untrack-css.sh && sh installers/postinstall/postinstall.sh && npm run install-fonts
    
    MagicMirror installation successful!
    
    magicmirror@2.9.0 install-fonts /home/pi/MagicMirror
    cd fonts && npm install
    
    audited 1 package in 1.49s
    found 0 vulnerabilities
    
    npm WARN grunt-stylelint@0.11.1 requires a peer of stylelint@^10.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN acorn-jsx@5.0.2 requires a peer of acorn@^6.0.0 || ^7.0.0 but none is installed. You must install peer dependencies yourself.
    
    added 1044 packages from 1317 contributors and audited 3477 packages in 351.357s
    found 0 vulnerabilities
    


  • @unknownuser26 yes, they added checking for hacker vulnerabilities…

    one cannot fix them all… so, run audit fix once, and ignore the rest… they are just warnings



  • @sdetweil said in MagicMirror wont start after failed update:

    yes, they added checking for hacker vulnerabilities…
    one cannot fix them all… so, run audir fix once, and ignore the rest… they are just warnings

    Thank you for your help



  • @unknownuser26 my pleasure


Log in to reply