MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

turn magic mirror black or fade dark



  • Hi
    I running Magic Mirror as server only and use two old iPad 2 to show my information.
    But is it possible to remote send info to the server to show black screen or fade very dark.

    Why I ask is because at night the iPad 2 works as a light and can light the entire room when the iPad is on.
    I do not think I can turn off iPad remote so my only option is to see if it is less bright when I have just a black screen.


  • Project Sponsor

    @cazz use mmm-remote and one of the page/profile modules to just display a black background/empty page.



  • this sounds interesting… i will play with making my MMM-Sleepwake detect device motion and hide all the modules on no motion after a timeout…

    and u have multiple iPads doing this at the same time? so i t run locally on each…



  • Thanks for the replay
    I going to try both, first with MMM-Sleepwake to see if it going to works like I want to.
    I going to use my Home Assistant that have a IR connected or even try with a timer to see how it works.



  • @cazz SleepWake hides the remotes, but doesn’t know how to wake up…



  • @sdetweil
    Hmm well I did try a little and add this code

    {
        module: 'MMM-SleepWake',
        delay:  15,               // default
        source: 'external',
        mode:  'HIDE',
    }
    

    and I was hopping it was going to turn black screen (when it hide clock, calender,JSONTable and backgroundslideshow) but nothing happend when I run this command on same server that have MM

    /home/{userid}/MagicMirror/modules/MMM-SleepWake/external_motion ended
    

    I have change the userid to the account I have on the server but I get no error at all so I guess I have miss something



  • @cazz Ended means no more motion, so timer starts. And in 15 minutes will go to sleep.

    I will try in serveronly mode later tonight



  • @cazz

    I set my server to serveronly and changed the timeout to 3 minutes for testing (from 5 normally)

    and all three clients went to sleep at the same time.

    now, the two mobile devices show the browser address line… not sure how to turn that off, cause that is a Kiosk mode value… there is an api to go to fullscreen mode, but it must be initiated by a user gesture… looking at how to get around that…

    haven’t got ipad to generate motion events yet…



  • Hmm strange, at first I did not know that 15 mean in minute, was thinking it was secund. But I did change it and sett 1 in the deplay

    {
        module: 'MMM-SleepWake',
        delay:  1,
        source: 'external',
        mode:  'HIDE',
    }
    

    But it still show everything even after I run the command and wait 1 minute.
    maybe “hide” option does not work so good?



  • @cazz hm… works for me… just changed timeout to 3 from 5…

    i fixed the doc to indicate minutes


Log in to reply