MMM-MyCommute not showing up.



  • I can’t get my MMM-MyCommute to show up.


    Thats my config.
    I’ve followed the instructions from https://github.com/jclarke0000/MMM-MyCommute and got a API key from the link provided.

    I might’ve chosen the wrong kind of API key tho, I took the Distance Matrix API since it provides travel time and distance for multiple destinations.

    alt text

    MyCommute does not show up when I open developer console, select the console tab and seach for MyCommute.



  • @Doogain Did you add the module into the MagicMirror/config/config.js?



  • @Doogain that is NOT your ‘config’… that is the module source.
    my general rule, you never edit the module source, unless u are doign something special, like extending its functionality

    to install a module you do

    cd ~/MagicMirror/modules
    git clone ??? 
    

    where ??? is the module github url

    then when that completes, you add a

        { 
              module:   ??? ,
              config: {
              }
        },
    
    to the modules array in config/config.js
    
    the required data for the config entry will be found in the README.md file in the module folder just created by the git clone operation


  • @buzzkc said in MMM-MyCommute not showing up.:

    @Doogain Did you add the module into the MagicMirror/config/config.js?

    That might be the issue, I didnt know I had to do that. Never installed a module before.

    @sdetweil said in MMM-MyCommute not showing up.:

    @Doogain that is NOT your ‘config’… that is the module source.
    my general rule, you never edit the module source, unless u are doign something special, like extending its functionality

    to install a module you do

    cd ~/MagicMirror/modules
    git clone ??? 
    

    where ??? is the module github url

    then when that completes, you add a

        { 
              module:   ??? ,
              config: {
              }
        },
    
    to the modules array in config/config.js
    
    the required data for the config entry will be found in the README.md file in the module folder just created by the git clone operation
    

    I already did the first part, its the last part that I think I’ve screwed up on. I’ll give a go now, will post back soon.



  • So I added this to config.js in MagicMirror/config
    {
    module: “MMM-MyCommute”,
    position: “top_left”,
    header: “Traffic”,
    classes: “default everyone”,
    },

    I recieved this error in developer console now
    alt text



  • @Doogain
    Your config entry should look more like the one in the Readme.md page of the module (https://github.com/jclarke0000/MMM-MyCommute)

    Also, be sure you followed all of the installation notes in the readme.

    {
      module: 'MMM-MyCommute',
      position: 'top_left',
      config: {
        apikey: 'API_KEY_FROM_GOOGLE',
        origin: '65 Front St W, Toronto, ON M5J 1E6',
        startTime: '00:00',
        endTime: '23:59',
        hideDays: [0,6],
        destinations: [
          {
            destination: '14 Duncan St Toronto, ON M5H 3G8',
            label: 'Air Canada Centre',
            mode: 'walking',
            color: '#82E5AA'
          },
          {
            destination: '317 Dundas St W, Toronto, ON M5T 1G4',
            label: 'Art Gallery of Ontario',
            mode: 'transit'
          },
          {
            destination: '55 Mill St, Toronto, ON M5A 3C4',
            label: 'Distillery District',
            mode: 'bicycling'
          },
          {
            destination: '6301 Silver Dart Dr, Mississauga, ON L5P 1B2',
            label: 'Pearson Airport',
            avoid: 'tolls'
          }
        ]
      }
    }
    


  • @Doogain u modified the module source. Please remove yours, and customize the config.js



  • I reverted the module source, I messed up bigtime on that. The modules show up in MM now, and that is so great! Thanks a lot!

    It does give a me a error instead of commute time tho, I think thats a either a API or adress error.
    Which API do I have to select from google? It gives me several choices.



  • I believe it’s the Maps Javascript API>>Directions API



  • @buzzkc said in MMM-MyCommute not showing up.:

    I believe it’s the Maps Javascript API>>Directions API

    Hmm still getting a error where it should say commute time.
    It says:
    MMM-MyCommute: You must enable Billing on the Google Cloud Project at https://console.cloud.google.com/project/_/billing/enable Learn more at https://developers.google.com/maps/gmp-get-started

    I already have that enabled tho.