MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MagicMirror Newsfeed continually "loading"...



  • if you do a

    pm2 stop 0
    

    then from a command prompt, even over ssh

    npm start 
    

    you will see messages , here is the default set of stuff,
    see that last entry

    Starting MagicMirror: v2.9.0
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: updatenotification
    No helper found for module: clock.
    Initializing new module helper ...
    Module helper loaded: calendar
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper ...
    Module helper loaded: newsfeed
    All module helpers loaded.
    Starting server on port 8080 ...
    You're using a full whitelist configuration to allow for all IPs
    Server started ...
    Connecting socket for: updatenotification
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started ...
    Launching application.
    Create new calendar fetcher for url: http://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics - Interval: 300000
    Create new news fetcher for url: http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml - Interval: 300000
    


  • @sdetweil
    Nope, I’m missing the last two lines:

    pi@raspberrypi:~/MagicMirror $ pm2 stop 0
    npm start [PM2] Spawning PM2 daemon with pm2_home=/home/pi/.pm2
    
    [PM2] PM2 Successfully daemonized
    [PM2] Applying action stopProcessId on app [0](ids: 0)
    [PM2][ERROR] Process 0 not found
    pi@raspberrypi:~/MagicMirror $ npm start 
    
    > magicmirror@2.9.0 start /home/pi/MagicMirror
    > sh run-start.sh
    
    Starting MagicMirror: v2.9.0
    Loading config ...
    Loading module helpers ...
    Initializing new module helper ...
    Module helper loaded: updatenotification
    No helper found for module: helloworld.
    All module helpers loaded.
    Starting server on port 8080 ... 
    Server started ...
    Connecting socket for: updatenotification
    Sockets connected & modules started ...
    Launching application.
    
    

    Also looks like the helper module doesn’t get loaded…?



  • @ForeverBrewing ok, can u do

    ls ~/MagicMirror/config -laF
    ls ~/MagicMirror/modules/default -laF
    


  • @sdetweil said in MagicMirror Newsfeed continually “loading”...:

    ls ~/MagicMirror/config -laF
    ls ~/MagicMirror/modules/default -laF

    pi@raspberrypi:~/MagicMirror $ ls ~/MagicMirror/config -laF
    total 20
    drwxr-xr-x  2 pi pi 4096 Nov 13 18:17 ./
    drwxr-xr-x 17 pi pi 4096 Nov 12 20:25 ../
    -rw-r--r--  1 pi pi 3437 Nov 13 17:35 config.js
    -rw-r--r--  1 pi pi 2769 Nov 10 14:36 config.js.sample
    -rw-r--r--  1 pi pi   20 Nov 10 14:36 .gitignore
    pi@raspberrypi:~/MagicMirror $ ls ~/MagicMirror/modules/default -laF
    total 52
    drwxr-xr-x 12 pi pi 4096 Nov 12 21:29 ./
    drwxr-xr-x  6 pi pi 4096 Nov 10 18:20 ../
    drwxr-xr-x  3 pi pi 4096 Nov 10 14:36 alert/
    drwxr-xr-x  3 pi pi 4096 Nov 10 14:36 calendar/
    drwxr-xr-x  3 pi pi 4096 Nov 10 14:36 clock/
    drwxr-xr-x  2 pi pi 4096 Nov 10 16:35 compliments/
    drwxr-xr-x  2 pi pi 4096 Nov 10 14:36 currentweather/
    -rw-r--r--  1 pi pi  520 Nov 10 14:36 defaultmodules.js
    drwxr-xr-x  2 pi pi 4096 Nov 10 14:36 helloworld/
    drwxr-xr-x  2 pi pi 4096 Nov 12 21:32 newsfeed/
    drwxr-xr-x  2 pi pi 4096 Nov 10 14:36 updatenotification/
    drwxr-xr-x  3 pi pi 4096 Nov 10 14:36 weather/
    drwxr-xr-x  2 pi pi 4096 Nov 10 14:36 weatherforecast/
    

    Thank you so much for your time with this btw 🙂



  • @ForeverBrewing said in MagicMirror Newsfeed continually “loading”...:

    Thank you so much for your time with this btw

    no problem… like to help…

    but the output doesn’t match the config at all… there should be more info about the other modules and errors if they were not found…



  • @sdetweil

    Well I guess installing a fresh copy wont be too much hassle! Its not like I cant work out how to get the google assistant to work anyway, so I’ll probably just keep it completely vanilla. Even I cant balls that up too much…



  • @ForeverBrewing use the updated installer… see https://forum.magicmirror.builders/topic/10171/anyone-want-to-try-updated-installer
    you should rename the current MM folder out of the way… then u can copy files over if need be



  • @sdetweil

    Will do, thanks for your help 🙂



  • For those googling this problem, consider whether you added the module to your config file but didn’t stop and restart the software. Many config changes can take effect just by saving the config file and reloading the browser window, but adding and removing modules…not so much 🙂



  • @spblat if the module has a node_helper.js, you need to restart MM for any changes to take place


Log in to reply