MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

How I got my Magic Mirror working on a Raspberry Pi 0 (zero)



  • @Kobie I’m worried it may be something with the limited processing power of the Pi. Since the scheduler relies on the remote module as well I double checked the remote module by trying to connect remotely from my phone, but the webpage would just hang. This may be an unrelated issue, but I’ll look into it more.

    When I shut down my mirror manually I see my email module is throwing errors in the background too so maybe that is drawing too many resources as well? Hard to say, I’ll report back if I find a solution.



  • @Kobie So even after I did all of my steps and there were no error I rebooted and came back to the terminal screen. I midori apparently didn’t launch. Also, after I did

    sudo cp config/config.js.sample config/config.js
    

    I was presented with a blank document. Is it supposed to have anything?



  • @randombullet I’m afraid I don’t think I can help much. I simply followed all the steps above and it worked for me. Perhaps you missed a step, but it would be hard to say what. Perhaps the easiest thing to do is to re-flash the jessi-lite image and go through the steps again 😞


  • Project Sponsor

    @randombullet I think your problem is with the sudo command. You shouldn’t need sudo to copy the config.js file. Check the permissions on the the config.js file. Make sure the npm process can read it.



  • @Kobie @Wieber Good news! Found out my mail module wasn’t connecting properly with my 2-step verification enabled. After switching to a “less secure app password” my mail app loaded correctly and no longer continued to stall and chew up resources in the background. As a result I was able to remotely connect once again and the scheduler works!



  • I followed all your steps… took me 4 tries to actually succeed (my very first Pi project ever)… but i get an error. It boots into MagicMirror2 but it says "please create a config file. See README for more information. " I went on GitHub and read the README file but no matter what i type in i cant find the config file. Please help me out. Huge thanks!!!



  • @SebTota Your MM2 is actually working, so you did not mess up 😃
    You just have to configure your MM in order to boot it properly. If you go to the /MagicMirror/Config/config.js.sample file you can add all the information your mirror needs (e.g. a link to a weather api, an RSS feed for news etc) you can safe the file with ‘crtl+x’, then change the file name to config.js (just remove the ‘.sample’ bit) and press ‘y’ (this is of the top of my head, but i’m sure you can figure it out, you just have to safe the file under a different file) and reboot!

    You don’t actually have to put in your personal edits (weather, calendar etc) for it to boot normally, it just needs an ‘config.js’ file for it to stop showing the message.

    Good luck!



  • @Burner911 Great to hear it’s all working now 😃



  • What the heck!! I got the error message. Reset the pi. Got the message again. Gave up, then when i saw you comment I said id give it another try. I boot it up and it works. I dont know if you have some magical powers your not telling anyone about, but man I love you right now.



  • @SebTota I might have received a letter from Hogwarts once, but I would have to kill you if I told you 😉
    Have fun with your mirror!