MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

ERRNO 126, ELIFECYCLE, permission denied on RPI3



  • Hi, thx lots for checking this out!

    I was just did a fresh install of MM on my rpi 3, the installation went fine. But when I tried to start MM by npm start or npm start dev, it fails n reports ERRNO 126, permission denied, and “this is probablity not a problem with npm…additional logging output above”.

    I’ve tried reinstalling MM, reinstalling raspbian (buster), running npm start as root, but still no luck.

    I’ve hooked up my rpi directly to a display via hdmi n everything works fine.

    npm ERR! code ELIFECYCLE
    npm ERR! errno 126
    npm ERR! magicmirror@2.10.1 start: `./run-start.sh`
    npm ERR! Exit status 126
    npm ERR! 
    npm ERR! Failed at the magicmirror@2.10.1 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2020-02-13T08_34_23_558Z-debug.log
    

    again thx lots!


  • Module Developer

    @someone123416
    can you make sure you are in the MagicMirror directory when you start the Mirror via npm start?
    You need to be in the correct directory for that to work.

    Also, please mkae sure you use code pattern for the output posted. I’ve edited it for you.



  • Thank you very much for your reply!

    Yes, I am in the MM directory (cd MagicMirror) before attempting to start.

    Sorry for the mistake w the output stuff. First time in this forum 😁


  • Module Developer

    @someone123416 Have you maybe installed MM with sudo priviledge, having a permission error?

    If you have just installed I would delete the magicmirror folder an reinstall everything and be careful not to sudo anything.
    Use the new installation and upgrade script for that. (i think it is described in the official readme.)



  • Ok, I will give that a shot today!

    Thx



  • @lavolp3 Hi, sorry for the very late follow-up, I was very occupied last week.

    I’ve cleared the micro sd card and started from scratch, reinstalling raspbian and MM without Sudo privilege or any type of permission restriction.

    The bad news is that it still gave the same error message. The good news is that I might’ve found the reason behind the failure. It seems to not be able to download nor install chromedriver.js. This might be caused by me being in mainland China right now, and the “great firewall of China” has blocked the download.

    Is there any other way to get the chromedriver.js files and manually put it into the MM folder?

    Thank you very much for your time!



  • @someone123416 try this…

    npm install --only=prod
    

    as the chromedriver is only needed for testing… which u won’t be doing…

    if you used the automated install script then you wouldn’t have these problems…
    see https://github.com/sdetweil/MagicMirror_scripts



  • Thank you, Sam, for your reply!

    MagicMirror installed successfully with the --only=prod command, the error code about chromedriver has disappeared.

    However, I am still getting the same error message (errno 126) when trying to npm start the program, in fact, the exact same error message.

    I am really curious about why I am getting a permission error, as I’ve installed it without any privileges.



  • @someone123416 did u erase the node_modules folder

    cd ~/MagicMirror
    rm -rf node_modules
    npm install --only=prod
    


  • @sdetweil Hi Sam,

    Thank you very much for your reply.

    I’ve tried earasing the node_modules folder, but still no luck. Exact same error message.


Log in to reply