MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

YA Troubleshooting: MMM-AssistantMk2 + MMM-Hotword Thread



  • Hi,
    I am aware that there are multiple threads on troubleshooting the Google Assistant, but I did not find one on systematical troubleshooting. How do I test what is not working? Below please find my attempts, which may be a first start, but did not identify the root cause.
    Now I am stuck with my MMM-AssistantMk2 and MMM-Hotword installation and configuration and look for step-by-step troubleshooting. When I started the Google Assistant installation, all installed MM modules are working fine, so I imaged the SD-card for an easy fallback.

    My steps have been:

    1. Installing MMM-AssistantMk2 + MMM-Hotword
    2. Now I get a flashing bubble on the mirror and whenever I say the magic word: “smart-mirror” the string [“smart-mirror”] shows up next to the bubble on my Magic Mirror, but nothing seems to happen after (similar to the image on this page, just my hotword is not “Computer” but “smart mirror”: https://github.com/eouia/MMM-Hotword)

    Maybe most of the things are successfully implemented but how do I get it to work?
    I have no clue why or where it hangs, what are steps to identify where it stucks?

    So far I have checked the following:

    Version checks::
    pi@raspberrypi:~/MagicMirror $ uname -a
    Linux raspberrypi 4.19.34-v7+ #1211 SMP Mon Apr 8 22:56:37 BST 2019 armv7l GNU/L

    pi@raspberrypi:~/MagicMirror $ vcgencmd version
    Mar 27 2019 15:45:53
    Copyright © 2012 Broadcom
    version 2e98b31d18547962e564bdf88e57b3df7085c29b (clean) (release) (start)

    pi@raspberrypi:~/MagicMirror $ node -v && npm -v
    v10.15.3
    6.9.0

    These commands resulted in long outputs, but did not point me to anything useful:
    pi@raspberrypi:~/MagicMirror/config $ npm start dev
    pi@raspberrypi:~ $ dmesg -x -d -T

    Audio checks:

    Speaker check:
    pi@raspberrypi:~ $ aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
    Sub-Geräte: 7/7
    Sub-Gerät #0: subdevice #0
    Sub-Gerät #1: subdevice #1
    Sub-Gerät #2: subdevice #2
    Sub-Gerät #3: subdevice #3
    Sub-Gerät #4: subdevice #4
    Sub-Gerät #5: subdevice #5
    Sub-Gerät #6: subdevice #6
    Karte 0: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0

    Microphone check:
    pi@raspberrypi:~ $ arecord -l
    **** Liste der Hardware-Geräte (CAPTURE) ****
    Karte 1: AK5371 [AK5371], Gerät 0: USB Audio [USB Audio]
    Sub-Geräte: 0/1
    Sub-Gerät #0: subdevice #0

    Audio Check:
    arecord -D plughw:1,0 -d 3 test.wav && aplay test.wav
    I hear myself speaking when the pm2 is stopped

    Google Credentials and Setup check:
    pi@raspberrypi:~/MagicMirror/modules/MMM-AssistantMk2 $ node auth_and_test.js
    Type your request:
    googlesamples-assistant-pushtotalk --project-id magicmirror-12345 --device-model-id magicmirror-12345-magicmirror-123456
    Assistant Response:
    Conversation Complete

    This section highlights some findings:

    pi@raspberrypi:~/MagicMirror $ npm run config:check

    magicmirror@2.10.1 config:check /home/pi/MagicMirror
    node tests/configs/check_config.js

    Checking file… /home/pi/MagicMirror/config/config.js
    Line 56 col 56 ‘arrow function syntax (=>)’ is only available in ES6 (use ‘esversion: 6’).
    Line 57 col 55 Missing semicolon.

    Note: fixing the [“Line 57 col 55 Missing semicolon.“]-issue does not make a difference, I copied-and-pasted this part from here: https://github.com/makepluscode/rpi-tutorial-advanced/tree/master/008-raspbian-magicmirror-google-assistant-latest
    The audio/mic-settings in this sample seem to match my setup?

    Does anybody have any idea what the next appropriate steps are to find where it hangs?
    Any help is very much appreciated.

    Cheers
    Bob


Log in to reply