MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

mmm-Remote-Control issues



  • Hello, I’m having difficulty getting access. I have changed the config.js file multiple times to no affect. All the things I have read talk about IP addresses in the 192 range, but all mine are 10.0.0.xxx. I have added the IPs of my phone and laptop to the config but it just doesn’t work. Here are the settings currently:

    var config = {
    	//address: "localhost", // Address to listen on, can be:
    address: "0.0.0.0",
    	                      // - "localhost", "0.0.0.0", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out or empty, is "localhost"
    	port: 8080,
    	ipWhitelist: ["::fff:10.0.0.110", "::fff:128.0.0.0/2", "::fff:192.0.0.0/3", "::fff:224.0.0.0/4", "127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    

    and here is the module in my config.js file:

    {
            module: 'MMM-Remote-Control',
            // uncomment the following line to show the URL of the remote control on the mirror
            position: 'bottom_left',
            // you can hide this module afterwards from the remote control itself
            config: {
            //customCommand: {},  // Optional, See "Using Custom Commands" below
            //customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
            //showModuleApiMenu: true, // Optional, Enable the Module Controls menu
            apiKey: "",         // Optional, See API/README.md for details
            }
    


  • @mrlowndes remove everything from the ipWhitelist



  • @sdetweil so the whitelist doesn’t work?



  • @mrlowndes it does, but 1st thing is to get connected


Log in to reply