MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Zoom config ignored in server mode?



  • My “mirror” is actually being used as a desktop display, running on a Pi-Top Ceed with a 14" display on it. Got it set up exactly as I want, using a config file zoom setting of 0.6. On the display it works perfectly.

    Just now experimented with setting the mirror up as a server as well by tweaking the address and ipWhitelist, and whilst it’s also working I notice that it’s not taking the zoom config entry into account that way.

    If I just connect to the mirror with Chrome on my PC everything is oversized and all the modules are covering each other. Changing the zoom in Chrome to either 50% or 67% makes it look fine (annoyingly Chrome can’t be set to 60%!).

    Just thought I’d report it here anyway. Not a major issue at all, but for completeness towards making this excellent project perfect 😁



  • @DarrenHill correct…we have the ability to tell electron the embedded browser to zoom on start, we cannot do that for the browser that just gets the html file from the server port.

    chrome should remember after the 1st setting, so it should only bother you once!



  • Thanks, that makes sense, and indeed Chrome is happily remembering the setting too.

    I wasn’t sure whether the zoom was being applied pre- or post-rendering. But your explanation makes sense, and the solution of doing it “manually” works fine.


Log in to reply