MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

PIR-module -> NODE_MODULE_VERSION...



  • Hey mirrorfans, one week ago i startet my first Mirror project and every module i installed worked perfectly. But the modules “MMM-PIR” or “MMM-PIR-Sensor” are getting me mad.

    As every modules i followd the discription to install but i did not get the modules to run. I Always get These errorcode :

    " WARNING! Could not load config file. Starting with default configuration. Error found: Error: The module ‘/home/pi/MagicMirror/modules/MMM-PIR/node_modules/epoll/build/Release/epoll.node’
    was compiled against a different Node.js version using
    NODE_MODULE_VERSION 64. This version of Node.js requires
    NODE_MODULE_VERSION 73. Please try re-compiling or re-installing
    the module (for instance, using npm rebuild or npm install). "

    Two days i googled the Problem and tried many Things (reinstall,rebuild,delete node_modules etc) but i have to confess i really dont know what to do 😕 . Please help me.

    greets pw



  • @pw94 I was never able to get either of those to run for me. I ended up copying the python script from https://www.putorius.net/using-pir-sensor-for-motion-detection.html and it’s been working fine.



  • @pw94
    I had issues also running those PIR mods… the only mod that worked for me was ‘MMM-NewPIR’,
    I love this module. It also has the ability to not TURN OFF the display but rather just throw up a black screen or “hide” the modules .

    my config for MMM-NewPIR is below if it helps any.

          	        {
    		  	module: 'MMM-NewPIR',
    			position: 'bottom_left',
    			config: {
    				useSensor: true,
    				sensorPin: 22,
    				reverseValue: false,
    				delay: 2* 60 * 1000,
    				turnOffDisplay: false,
    				ecoMode: true,
    				governor: "",
    				text: "",
    				counter: false,
    				rpi4: true,
    				debug: false
    			}
    		},
    

Log in to reply