MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Fuel does not show any data



  • Hi there,

    I am quite new to MagicMirror and added some modules successfully, but currently I am struggling with MMM-Fuel. No gas stations are shown at all.

    This is my config:

    {
    module: "MMM-Fuel",
    position: "top_right",
    config: {
    //types: ["diesel"],
    //provider: "tankerkoenig",
    api_key: "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxx",
    lat: "52.285583",
    lng: "6.835616"
    }
    },
    

    I can not find any errors in the development window



  • Uncomment (remove) the // from types and provider.
    I suppose you registered on tankerkoenig.de and obtained an actual API key and are not running with xxxxxxx-xxx-xxx API key?



  • Hey,

    yes, I’ve tried to remove the // parts and the API is inserted as well.
    It still does not work 😞



  • @phistix so, lets look at the logs. how do you start mm? npm start or pm2

    if pm2, then
    pm2 logs --lines=100
    will show the node_helper messages

    if npm start, then the messages will be shown in the terminal window where u issued the npm start command.
    u may have to minimize mm to see that window (alt-spacebar, n to minimize)

    we also need to look at the browser messages, by opening the developers window. ctrl-shift-i, then select the tab labeled console and scroll up to see any error messages. you can also filter messages to a particular module, by putting part of the module name in the filter field, fuel, in this case.

    did u do the npm install after doing the git clone?, as the module depends on some libraries not avail by just install



  • Hey!

    Have you confirmed the e-mail? Otherwise the API key cannot be used. I just did it yesterday for my test project on a VM, it worked without problems.
    I can send you a screenshot to show you. I guess you must have made a little mistake somewhere.

    I just sat down and requested a new API key, this one works too.

    It’s my first post, so I had to wait 10 minutes. In this time I made a screenshot for you 🙂

    alt text

    (im an German, if you are too, you can write me in german 😛 )



  • Hey,

    thanks for the answers.

    I start mm via pm2.
    pm2 logs --lines=100 shows me no errors.
    Development windows doesn’t show me errors as well.

    I tried with a second API key, but still not working. And yes I confirmed the email.
    spritpreise.png

    I installed manually “fs-extra” and “node-fetch” and I did a npm install in the MMM-Fuel folder, but it did not change anything.
    Can I somehow “uninstall” the module and the needed packets to restart from scratch?

    Und ja, ich bin deutsch @CanbiZ 🙂



  • Hi @phistix ,

    when I check your “lat” and “lng” you have in your config, it looks you are located in the netherlands…may be therefor, tankerkönig has no data for this place. So please check it again:-)

    Greetings from Bonn
    Thomas



  • @thgmirror

    Exactly, that would have been my next theory, check the coordinates and I think you have to specify a type (diesel).



  • Thank you all for your help.

    It finally worked,
    I don’t know why, but my coordinates were wrong.
    I thought I copied them correctly from another source, but I did not.


Log in to reply