MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-MyCommute Module Working But Hidden??



  • Hi there, I’m super new to this and have been figuring out my way with adding some modules and last night I had the MMM-MyCommute module finally working and then when I added another module it for some reason made my other one disappear. I eventually gave up on trying to get it back and decided to start completely over, re-installed Pi OS and Magic Mirror, downloaded the MyCommute module again and it’s in my config file but still nothing is showing up… please help!



  • I am having the same issue. I installed MyCommute for the first time and nothing is showing up (even header “My Commute” doesn’t come up on the screen). I used the by default config given on the page (mentioned at the end). Initially I thought it may be because of API key or any request issues to the Directions API, so I installed MMM-Traffic module just to see if I am seeing problems there but that one works (it does show the time to the destination). Any help is appreciated 🙂 And thank you for creating such an awesome module 🙂

    This is the config I used for MyCommute
    {
    module: ‘MMM-MyCommute’,
    position: ‘top_center’,
    config: {
    apiKey: ‘XXXXXXXXXXXXXXXXXXXXXXXXXX’,
    origin: ‘65 Front St W, Toronto, ON M5J 1E6’,
    destinations: [
    {
    destination: ‘14 Duncan St Toronto, ON M5H 3G8’,
    label: ‘Air Canada Centre’,
    mode: ‘walking’,
    color: ‘#82E5AA’
    }
    ],
    // Additional config for calendar routes:
    maxCalendarEvents: 2,
    calendarOptions: [
    {
    mode: ‘driving’
    },
    {
    mode: ‘transit’,
    transitMode: ‘train’
    }
    ]
    }
    },


  • Module Developer

    @scarecrow I assume you installed from the fork that includes the calendar options and not from the origin rep by jclarke0000?
    The additional options are not part of the original repository and might lead to problems.



  • @lavolp3 said in MMM-MyCommute Module Working But Hidden??:

    jclarke0000

    Yes that’s right, I installed it from the fork. This is the rep.
    Cool, I will uninstall that and try it with the original repository

    Thanks!



  • It worked after using the original repo


Log in to reply