MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

I can't use Youtube while lag is en-US



  • Hi, im a student in South Korea.
    I just updated mmm-AssistantMk2 to MMM-GoogleAssistant and MMM-Assistant2Display.

    here’s the problem:

    1. I want to use this Magic mirror in my native language Korean. So i put ko-KR instead en-US.
    2. than Ive tried to watch Youtube, it doesnt work.
    3. Besides, other functions (Scheduler, Reminder, Searching “Dokdo” things.)
    4. And the words that I said appears down below in blank where it should be.

    So I tried to:

    1. changed Language to en-US.
    2. thus, Youtube works somtimes, BUT it just play what I dont wanna see. (ex:If I say Michael Jackson" Thriller youtube, It says Heres the result from Youtube, and It doesnt work at all.

    Here’s my config.js:

    var config = {
    address: “localhost”,
    electronOptions: {
    webPreferences: {
    webviewTag: true
    }
    },
    port: 8080,
    ipWhitelist: [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”],
    language: “ko”,
    timeFormat: 12,
    units: “metric”,

    modules: [
    {
    module: “alert”,
    },
    {
    module: “updatenotification”,
    position: “top_bar”
    },
    {
    module: “clock”,
    position: “top_left”,
    config: {
    dateFormat: “LL dddd”,
    }
    },
    {
    module: “calendar”,
    position: “top_left”,
    config: {
    urgency: 21,
    fetchInterval: 3600000,
    calendars: [{
    url: ‘https://calendar.google.com/calendar/ical/ko.south_korea%23holiday%40group.v.calendar.google.com/public/basic.ics’,
    symbol: ‘대한민국 공휴일’,
    }]
    }
    },
    {
    module: “currentweather”,
    position: “top_right”,
    config: {
    location: “Cheonan, KR”, //https://openweathermap.org/ 에서 지역을 찾으세요.
    locationID: “”,
    appid: “bb035e13e4962db6d5e39914bec2ad28” //openweathermap.org의 API key를 입력하세요.
    }
    },
    {
    module: “weatherforecast”,
    position: “top_right”,
    config: {
    location: “Cheonan, KR”, //https://openweathermap.org/ 에서 지역을 찾으세요.
    locationID: “”,
    appid: “bb035e13e4962db6d5e39914bec2ad28” //openweathermap.org의 API key를 입력하세요.
    }
    },
    {
    module: “compliments”,
    position: “lower_third”,
    config: {
    compliments: {
    anytime: [ //아무때나
    “오늘도 좋은 하루!”
    ],
    morning: [ //아침
    “좋은 아침!”,
    “힘찬 아침!”,
    “잘 잤나요?”
    ],
    afternoon: [ //오후
    “안녕하세요!”,
    “멋져요!”,
    “잘 지내고 있나요!”
    ],
    evening: [ //저녁
    “와우! 잘 지냈나요?”,
    “멋져보이네요!”,
    “반가워요!”
    ],
    day_sunny: [//맑은 낮

          ],
          day_cloudy: [//흐린 낮
    
          ],
          cloudy: [//흐림
    
          ],
          cloudy_windy: [//흐리고 바람
    
          ],
          showers: [//소나기
    
          ],
          rain: [//비
    
          ],
          thunderstorm: [//천둥번개
    
          ],
          snow: [//눈
    
          ],
          fog: [//안개
    
          ],
          night_clear: [//맑은 밤
    
          ],
          night_cloudy: [//흐린 밤
    
          ],
          night_showers: [//소나기 밤
    
          ],
          night_rain: [//비오는 밤
    
          ],
          night_thunderstorm: [//천둥번개 밤
    
          ],
          night_snow: [//눈오는 밤
    
          ],
          night_alt_cloudy_windy: [//흐리고 바람부는 밤
    
          ],
        }
      }
    },
    

    {
    module: “MMM-GoogleAssistant”,
    position: “middle”,
    config: {
    debug: false,
    assistantConfig: {
    lang: “ko-KR”,
    projectId: “”, // Required to use gaction.
    modelId: “”, // (OPTIONAL for gaction)
    instanceId: “”, // (OPTIONAL for gaction)
    latitude: 36.85,
    longitude: 127.15,
    },
    responseConfig: {
    useScreenOutput: true,
    screenOutputCSS: “screen_output.css”,
    screenOutputTimer: 5000,
    screenRotate: false,
    activateDelay: 250,
    useAudioOutput: true,
    useChime: true,
    newChime: false,
    useNative: false,
    playProgram: “mpg321”
    },
    micConfig: { // put there configuration generated by auto-installer
    recorder: “arecord”,
    device: “plughw:1,0”,
    },
    customActionConfig: {
    autoMakeAction: false,
    autoUpdateAction: false, // in RPI, gaction CLI might have some trouble.(current version should be 2.2.4, but for linux-arm, Google haven’t updated) so leave this as false in RPI. I don’t know it is solved or not.
    actionLocale: “en-US”, // At this moment, multi-languages are not supported, sorry. Someday I’ll work.
    },
    snowboy: {
    usePMDL: false,
    audioGain: 2.0,
    Frontend: true,
    Model: “smart_mirror”,
    Sensitivity: 1
    },
    A2DServer: {
    useA2D: true,
    stopCommand: “stop”,
    useYouTube: true,
    displayResponse: true
    },
    recipes: [ “with-MMM-TelegramBot.js” ],
    NPMCheck: {
    useChecker: true,
    delay: 10 * 60 * 1000,
    useAlert: true
    }
    }
    },
    {
    module: “MMM-Assistant2Display”,
    position: “top_left”,
    config: {
    debug:false,
    useYoutube: true,
    links: {
    useLinks: false,
    displayDelay: 60 * 1000,
    scrollStep: 25,
    scrollInterval: 1000,
    scrollStart: 5000,
    scrollActivate: false,
    verbose: false
    },
    photos: {
    usePhotos: false,
    displayDelay: 10 * 1000
    },
    volume: {
    useVolume: false,
    volumePreset: “ALSA”,
    myScript: null
    },
    briefToday: {
    useBriefToday: false,
    welcome: “brief Today”
    },
    screen: {
    useScreen: false,
    delay: 5 * 60 * 1000,
    turnOffDisplay: true,
    ecoMode: true,
    displayCounter: true,
    displayBar: false,
    displayStyle: “Text”,
    text: “Auto Turn Off Screen:”,
    detectorSleeping: false,
    governorSleeping: false,
    displayLastPresence: true,
    LastPresenceText: “Last Presence:”,
    rpi4: false
    },
    pir: {
    usePir: false,
    gpio: 21,
    reverseValue: false
    },
    governor: {
    useGovernor: false,
    sleeping: “powersave”,
    working: “ondemand”
    },
    internet: {
    useInternet: true,
    displayPing: false,
    delay: 2* 60 * 1000,
    scan: “google.fr”,
    command: “pm2 restart 0”,
    showAlert: true
    },
    cast: {
    useCast: true,
    castName: “MagicMirror_A2D”,
    port: 8569
    },
    spotify: {
    useSpotify: false,
    useIntegred: false,
    useLibrespot: false,
    connectTo: null,
    playDelay: 3000,
    minVolume: 10,
    maxVolume: 100,
    updateInterval: 1000,
    idleInterval: 10000,
    username: “”,
    password: “”,
    CLIENT_ID: “”,
    CLIENT_SECRET: “”,
    deviceDisplay: “Listening on”,
    usePause: true,
    typeArtist: “artist”,
    typePlaylist: “playlist”,
    typeAlbum: “album”,
    typeTrack: “track”
    },
    NPMCheck: {
    useChecker: true,
    delay: 10 * 60 * 1000,
    useAlert: true
    }
    }
    },
    ]
    };

    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== “undefined”) {
    module.exports = config;

    plz Help!!



  • @younseongshin
    Hello
    Have you check the YouTube wiki to activate it on console and Auth it?
    Here the wiki for assistant2display
    https://github.com/bugsounet/MMM-Assistant2Display/wiki/YouTube



  • @saljoke yup, I already installed all the way up and checked either. and it worked in english when I ask to “smartmirror, Youtube, MJ’s thriller” but it doesnt work with Korean.



  • @younseongshin I have seen this with other apps. the voice reco does not add the word spacing that the text translation does.

    I don’t know how to fix it for this app, but it is looking for distinct words.



  • @sdetweil than is there no way out from this translation and audio problem…? til developer fix this?



  • @younseongshin as I said, I do not know how to fix this problem for this module. u might look thru the files and see if u can find the korean locale file and check the syntax.

    I had the good fortune to find a user that did that for the last app with this problem

    I don’t see a korean translation file for either module. ga or a2d



  • @sdetweil Thx to your kindness for me. As you said I’ll also hope to find the way to solve. Thx again!!! 🙂


Log in to reply