[Pi Zero] Midori not using full vertical resolution - 1080x1920



  • Hi everybody,

    I’m running a Pi Zero with NOOBS installation and am having trouble getting a browser use the full resolution available - 1080x1920 (vertical fullHD monitor).

    When booting up to GUI, everything works properly, whole screen is used. Changing boot to console (autologin) and just starting midori, I get to this:

    https://i.imgur.com/5NwBX5l.png

    Overscan settings in config.txt did not have any influence, I’ve tried several different settings in config.txt (which I unfortunately did not write down), what would you suggest?

    Thank you for your help!

    Below are the contents of relevant config files.


    /boot/config.txt:

    # For more options and information see
    # http://www.raspberrypi.org/documentation/configuration/config-txt.md
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    framebuffer_width=1080
    framebuffer_height=1920
    framebuffer_depth=32
    framebuffer_ignore_alpha=1
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    ^M
    # NOOBS Auto-generated Settings:^M
    hdmi_force_hotplug=1^M
    
    

    /home/pi/start.sh (launched on startup by editing .bashrc):

    cd ~/MagicMirror
    node serveronly &
    sleep 30
    #sudo xinit /usr/bin/kweb -KJERLH http://localhost:8080
    sudo xinit /home/pi/startMidori.sh
    

    /home/pi/startMidori.sh:

    #!/bin/sh
    xset -dpms # disable DPMS (Energy Star) features.
    xset s off # disable screen saver
    xset s noblank # don’t blank the video device
    matchbox-window-manager &
    #midori -e Fullscreen -a http://localhost:808
    midori -e Fullscreen -a http://www.reddit.com
    
    


  • I might be far off here, but if you plug in a screen to your Pi and don’t look through VNC; what does it look like?

    Considering how VNC sessions sometimes seem to add a different GUI for the VNC session , and not using the one you see when you hook up an actual screen (Im no expert, as you can see, but I’ve seen this myself in my own setup. Which is when I kicked and screamed like a baby and uninstalled VNC - all ssh/putty from then on).

    Just a thought.



  • @creye There isn’t any difference, even with an actual monitor it looks like this. I’ve just been using VNC, since it’s more convenient in my setup.

    Anyway, after backip up the current state, I’m starting over with a fresh Jessie Lite installation, let’s see how that goes.



  • @meneldour hmm ok. Yeah, sorry cant be of more help. I did just that recently also, fortunately its not a huge thing just to reinstall and start over. =)

    Good luck!



  • Well, clean installation fixed the issue, not sure what the root cause was though.



  • @meneldour Awesome!



  • @meneldour Im thinking of switching my installation to a pi zero. What are your thoughts around the performance? Id probably be using things like PIR and bringing in data from OpenHAB, news, weather, calendar etc…



  • @Mar Hey, I’m not sure, if I can give you a proper report on the performance, I’ve got no experience with other raspi models and I’m still in the stage of building the software part.

    I can tell you though that the installation won’t be painless, there’s some stuff that needs manual updating. If you decide to go through with it and run into problems, hit me up, maybe I could help you out.



  • @meneldour thanks for the offer! I will give this a shot in a few days and will keep your offer in mind. Really appreciated! Im really excited for this.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.