MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

problem after switching rpi4



  • i switched to the rpi4 today and copied the MagicMirror folder from the rpi3 to my windows pc with WinSCP then copied everything back to the rpi4 and now i get this error (what do i do)
    the mirror does not start up

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
    2 info using npm@6.14.8
    3 info using node@v10.23.0
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle magicmirror@2.13.0~prestart: magicmirror@2.13.0
    6 info lifecycle magicmirror@2.13.0~start: magicmirror@2.13.0
    7 verbose lifecycle magicmirror@2.13.0~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.13.0~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    9 verbose lifecycle magicmirror@2.13.0~start: CWD: /home/pi/MagicMirror
    10 silly lifecycle magicmirror@2.13.0~start: Args: [ '-c',
    10 silly lifecycle   'DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js' ]
    11 silly lifecycle magicmirror@2.13.0~start: Returned: code: 126  signal: null
    12 info lifecycle magicmirror@2.13.0~start: Failed to exec start script
    13 verbose stack Error: magicmirror@2.13.0 start: `DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js`
    13 verbose stack Exit status 126
    13 verbose stack     at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
    13 verbose stack     at EventEmitter.emit (events.js:198:13)
    13 verbose stack     at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    13 verbose stack     at ChildProcess.emit (events.js:198:13)
    13 verbose stack     at maybeClose (internal/child_process.js:982:16)
    13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
    14 verbose pkgid magicmirror@2.13.0
    15 verbose cwd /home/pi/MagicMirror
    16 verbose Linux 5.4.72-v7l+
    17 verbose argv "/usr/bin/node" "/usr/bin/npm" "start"
    18 verbose node v10.23.0
    19 verbose npm  v6.14.8
    20 error code ELIFECYCLE
    21 error errno 126
    22 error magicmirror@2.13.0 start: `DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js`
    22 error Exit status 126
    23 error Failed at the magicmirror@2.13.0 start script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 126, true ]
    


  • @raf do

    cd ~/MagicMirror
    rm -rf node_modules
    npm install --only=prod
    

    then try to restart mm
    if u have extra modules u may need to do npm install in their folders…

    u should have use zip or tar to collect all the files, copied that bundle
    then restored on pi4



  • @sdetweil

    it works back, i reinstalled the mirror and copied the modules folder back from the win pc to the pi and restarted the config.js and it worked


Log in to reply