MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

My MM lost power and did not come back up. :(



  • My MagicMirror lost power and did not come back up. The pi itself powers up but the software (OS) did not load. There was a rapid blinking cursor in the top left corner.

    So, I downloaded the latest Raspian version and got it installed to a micro sd card. Put the card into the pi and it booted up fine (regular pi OS, not NOOBS). Configured the WiFi, set a static IP, changed the (pi) password and enabled SSH.

    Connected to the pi using SSH and updated the system by using “sudo apt update” and “sudo apt full-upgrade”.
    The pi is currently running: VERSION=“10 (buster)”.

    So pretty happy with what I have so done so far! I figured that since I had copied the whole MagicMirror directory after I had it configured the first time, I could install MM, copy the config files over and be good to go!

    So I headed over to github (https://github.com/sdetweil/MagicMirror_scripts) and read quickly through it. Opened up an SSH session and tried to run the installer script.

    $(curl -sL https://raw.githubusercontent.com/sdetweil/MagicMirror_scripts/master/raspberry.sh)
    

    No bueno. 😞

    When I run the script as above, here is the error message.
    -bash: #!/bin/bash: No such file or directory

    I am pretty sure I am missing something extremely simple or at least I hope I am. Would appreciate any help.



  • So I just wanted to post an update instead of just deleting this post. Hopefully me being a doofus will help someone who may have the same issue.

    I forgot to include the leading " bash -c " before the script. It is installing now.
    So I should have been typing in:

    bash -c "$(curl -sL https://raw.githubusercontent.com/sdetweil/MagicMirror_scripts/master/raspberry.sh)"
    


  • @TomBrownand if u are using ssh, just copy/paste the line.

    ps, its does all the updates. And installs node and npm. So u don’t have to anything but build the card


Log in to reply