MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

[MMM-RadioDe] - Simple Web player

  • Description:

    This is an extension for the MagicMirror. It can show/hide a webradio stream provided by You can start and stop this web radio stream by hiding the module. It uses the suspend/ resume method of MagicMirror for this. Currently the setup is rather simple. Potential extensions for the future might be selection of the radio station via remote control plugin, tuning of volume. Currently I do use the module to start in the evening the favorite radio channel of my children and to stop it again once they do sleep.


    alt text


    Version 0.1.0

    • First initial commit
    • Feedback highly welcome!

  • First of all awesome add on for my mirror 🙂
    I seem to have a problem…

    The radio station ssms to load normally on my magicmirror remote on my desktop but doesnt load the station when on my mirror itself. Cant really find anything wrong because its working when checking it remotely.

    The browser plugin shows but does not start, but only on the mirror itself.

  • Which radiostation is ssms ? Might it be possible that does not cover this radio station ? Normally I can start directly in the webbrowser my desired radio station by , e.g. If I however try to start I am redirected to the home page of So my interpretation is that the station name might be differently for In order to help you it would be helpful to get full station name. If it is the super saturday morning show, it looks like does not reference it. This would mean that my plugin will not work you.

  • Sorry man I let you the wrong direction.
    I’m using SLAM, is covering my station as it will work when I connect to the mirror remotely (via local ip:8080) but not on the mirror itself.

    I even tried it with Antenne, the standard option but works in remote, not on the mirror itself.

  • Hm, Just tried it in my own MMM, with following config:

            module: 'MMM-RadioDe',
            position: 'top_right', // This can be any of the regions.
            classes: 'scheduler',
            config: {
                    // PLAY RADIO BETWEEN 18:50 and 21:00 EVERY DAY
                    //module_schedule: {from: '50 18 * * *', to: '00 21 * * *' },
                    // See 'Configuration options' for more information.
                    api_key: 'xxxxxxxx',
                    station: 'slam'

    In my case it immediately start on my magicmirror:

    You mention that it does not start, did you set potentially the autoplay option to false ?

    Could you please post your config ?

  • {
                           module: 'MMM-RadioDe',
                           position: 'bottom_left', // This can be any of the regions.
                           config: {
                                   // See 'Configuration options' for more information.
                                   station: "antenne",
                                   // can be obtained in embed section of station, e.g.
                                   api_key: 'xxx',
                                   height:"92", // in pixel
                                   width:"360", // in pixel

    This is my config.
    The weird is it is working when I go to but not on the mirror itself

    This is the player on the mirror itself
    alt text

    This is on the webbrowser (
    alt text

    just tried it out with antenne lel

  • @Disturbx Honestly I am completely clueless. I did some updates today to several modules and now my MMM crashes after some time. I am not sure whether it is related to the radio module. I am currently debugging this, potentially I get an idea from this. The only thing I can offer you is to post you a configuration how you could to the similar setup with the iFrame module, if you are interested in. (Without station select, start/ stop via hide mechanism)

  • This post is deleted!

  • Hey @Steff, any updates on the module and how its not working with mine?

  • @Disturbx Wanted to post a reply already yesterday, but was too stupid to use git push…, I modified the behavior slightly, letting the module wait until the others are started, added as well some changes. I put them to the develop branch, so if you change your git to develop, you can try whether this helps.
    How to do:
    Enter local directory of module --> git checkout develop --> git pull
    Why develop branch ? I did only test on my development platform, but not on the Raspi itself.
    Feedback highly welcome

Log in to reply