MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

UNMET PEER DEPENDENCY on upgrade. Should I worry?

  • Just updated to latest MM, and got the following error:

    npm WARN grunt-yamllint@0.2.0 requires a peer of grunt@~0.4.0 but none was installed.

    Related error shown earlier in the install process:

    MagicMirror installation successful!
    magicmirror@2.1.1 /home/pi/MagicMirror
    \u251c\u2500\u252c chai@3.5.0
    \u2502 \u251c\u2500\u2500 assertion-error@1.0.2
    \u2502 \u251c\u2500\u252c deep-eql@0.1.3
    \u2502 \u2502 \u2514\u2500\u2500 type-detect@0.1.1
    \u2502 \u2514\u2500\u2500 type-detect@1.0.0
    \u251c\u2500\u252c chai-as-promised@6.0.0
    \u2502 \u2514\u2500\u2500 check-error@1.0.2
    \u251c\u2500\u2500 UNMET PEER DEPENDENCY grunt@1.0.1
    \u251c\u2500\u252c http-auth@3.1.3
    \u2502 \u251c\u2500\u252c apache-crypt@1.2.1
    \u2502 \u2502 \u2514\u2500\u2500 unix-crypt-td-js@1.0.0

    Should I be worried?

Log in to reply