node_helper modules not working with Pi One



  • I’m trying to get MagicMirror up and running on my Raspberry Pi One. I’ve got a config that’s trying to use the following 5 modules:

    • clock
    • currentweather
    • calendar
    • weatherforecast
    • my_ip (custom module to print the Pi’s IP address)

    I’ve got everything installed, and I run the server with “node serveronly”. Here are the weird things I’m seeing:

    1. Starting up the server prints the following. This seems odd because the final display is showing all the modules, so it clearly is loading the config:
      Loading config …
      WARNING! Could not find config. Please create one.
      Loading module helpers …
      No helper found for module: helloworld.
      All module helpers loaded.
      Starting server op port 8080 …
      Server started …
      Sockets connected & modules started …
      Ready to go! Please point your browser to: http://localhost:8080

    (When I use this config on my PC, it works correctly, and running “node serveronly” prints out a lot more messages like “No helper found for module: alert” and notes about starting node helpers)

    1. When I view the MagicMirror page from a browser (on my PC), I can see the clock, the currentweather, and the weatherforecast all working correctly. However, the calendar is blank and my my_ip module is blank. The primary difference I see between these modules and the other three are that they both use node_helper. I don’t see any output showing that the node helpers have started, which is also why I think this might be going wrong.

    Any suggestions on where to look or how to troubleshoot further? I’m not sure where to find any logs or error messages on the Pi from the MagicMirror. Right now I don’t have anything automated, I’m just running “node serveronly” directly from the command line on the Pi.

    Some other information:

    • I’m running raspian 4.1.19+ #858
    • I’ve run “sudo apt-get update && sudo apt-get upgrade -y” to make sure I’m up-to-date


  • More information:

    • It also happens if I just copy config.js.sample to config.js, so it has nothing to do with node_helper or my custom modules. Sorry for the false alarm there.
    • I added a bit of code to app.js to print out the exception being thrown, and it’s “TypeError: undefined is not a function” from the Object.assign call in loadConfig. I also added printouts of both defaults and c just above the Object.assign call, and they both appear to be loaded and correct.


  • Solved!

    I was running node v0.12.9. Once I upgraded to node v6.2.1 everything worked fine.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.