Error: ENOENT: no such file or directory, open 'package.json'



  • Hi!

    I’ve tried to install a new MagicMirror on a brand new Rpi3 with Raspbian Pixel using the automatic script bash -c "$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)".

    I had an error when pm2 was trying to be installed, saying that it couldn’t find the specified OS when doing: sudo su -c "env PATH=$PATH:/usr/bin pm2 startup linux -u pi --hp /home/pi". No worries there, I re-ran it with the right option and it worked. The problem is that when I start the mirror with: pm2 start MagicMirror, I get this error over and over again in the logs:

    0|MagicMir | Error: ENOENT: no such file or directory, open 'package.json'
    0|MagicMir |     at Error (native)
    0|MagicMir |     at Object.fs.openSync (fs.js:641:18)
    0|MagicMir |     at Object.fs.readFileSync (fs.js:509:33)
    0|MagicMir |     at Object. (/home/pi/MagicMirror/js/app.js:15:32)
    0|MagicMir |     at Module._compile (module.js:570:32)
    0|MagicMir |     at Object.Module._extensions..js (module.js:579:10)
    0|MagicMir |     at Module.load (module.js:487:32)
    0|MagicMir |     at tryModuleLoad (module.js:446:12)
    0|MagicMir |     at Function.Module._load (module.js:438:3)
    0|MagicMir |     at Module.require (module.js:497:17)
    

    I checked, in the mm.sh starting the script, there is the right cd. Also, when I manually start the mirror with: DISPLAY=:0 npm start, it works fine.

    Any ideas?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.