Blank black screen | Noob



  • So if I use Node serveronly I can see the mirror working just fine in my browser but as soon as I go into the terminal and type in pm2 start mm.sh that mirror is blank. I don’t know what else to do since this is my first time every working with a Raspberry Pi.

    I also have two MagicMirrors opening on startup


  • Moderator

    Confusing … you say you have two instances MM ‘opening’ at start up, and yet you are also trying to manually start it using 'pm2'? You can not run multiple instances of MM. When the first instance boots up, it binds to the configured port, and any instances after that will fail because they can’t bind to that port anymore.

    Along those same lines, you say you have two instances of MM ‘opening’ at start up, and you are trying to run it in 'serveronly' mode as well. Again, this will not work because the port is already bound to the first instance that came up. However, if after you execute the 'serveronly' setup, you don’t get any errors, that tells me you do not have any other instances running, despite you thinking there are two others running.

    So a few questions:

    • do you have MM installed in different folders?
    • are you launching them from different folders?
    • when you execute 'node serveronly', where are you typing that specifically, which folder?


  • Alright so at startup I have two instances running, one white and one black (both are blank).

    1. I have another folder that I messed up in so I deleted everything in it and just renamed it to something else. Currently it is empty. While the other folder, MagicMirror, is a clean install.
    2. Not manually. Is there a way I can disable MagicMirror from starting automatically?
      3.I’m typing ‘node serveronly’ in the MagicMirror folder (It works fine here after I close out all other instances of MagicMirror using ‘pm2 stop mm.sdh’

  • Moderator

    1. you can only run two separate instances of MM is they are on different ports, and for that to work, you will need two separate installations (in separate folders) because of the config file. They can not share it.
    2. Check on 'pm2' documentations on how to delete any configured startup process


  • Alright so I fixed the problem of the two instances opening but when I run ‘DISPLAY=:0 npm start’ It’s still blank.

    Any ideas on how to fix this? Like I said before it works when I use "node serveronly’


  • Moderator

    Go back to the beginning. Move your current config.js to something else, like config.js.backup. Then grab the original config.js and try running that, see if it comes up.

    You only need to set the DISPLAY=:0 if you are connecting remotely.



  • Did it using the sample config and renaming it to config.js. I still get a black screen, but if I do “node serveronly” with the same files it works in my browser.

    I’m getting no errors besides the “No helper found for module” (all of them)


  • Moderator

    With the default config.js you get a blank screen when you try to run 'npm start' ? If so, what’s the hardware? Have you updated the OS? All variables.



  • I used the automatic installer located here, https://github.com/MichMich/MagicMirror, and followed every step.
    I’m using a Raspberry Pi 3 Model B.
    I’m running Raspian Jesse 4.4, Node v4.4.3.
    The MagicMirror is up-to-date



  • @Arod192
    THIS is the setup that worked GREAT for me:
    https://forum.magicmirror.builders/topic/236/complete-setup-tutorial

    (Surprised KirAsh4 did not mention it. Follow it step by step; first time around will take you 30 min, but after that you will fly through it). Work. It really does.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.