Changing ipwhitelist prevents Mirror from loading correctly



  • Any changes I make to ipwhitelist prevent (or so it appears) MM from loading. This is true of anything I change it to other than the default. Everything seems to load normally―Pi boots up, desktop loads, launches MM. But, when the screen should load no modules populate. It just sits there… black… taunting me.

    I originally intended to use the whitelist filtering to tie into the Remote Control module, but that loads correctly. I can’t get it to allow access but I think that’s a result of whatever the hell is causing mirror to not load correctly.

    Any thoughts?

    So far I’ve tried every possible configuration, and variation of functioning (or should be) ip addresses, and/or ranges.

    I’ve tried including IPv6

    I’ve loaded a fresh, untouched config.js, made only changes to the whitelist and I get the same result.

    I’ve done everything I can think of short of reinstalling mirror and It’s dependancies.



  • @rcollie would be good to actually see what you tried exactly. Also can you check for errors in the electron console? and for logs in the terminal?



  • I can copy and paste the contents of config.js, but the issue occurs on the unaltered sample as well. Any change made to ipwhitelist causes the issue. At present there’s nothing listed―it’s default. So, the issue doesn’t occur. If I change it to:

    var config = {
    port: 8080,
    ipWhitelist: [],

    the issue occurs. It happens with any, and all ip variations. Hence my reason for not copying and pasting each one―it doesn’t matter what I change it to.

    I haven’t looked at the electron logs, because I can’t find them. I assumed they’d be in ~/.config/Electron/ , but they aren’t. Are they located elsewhere, or do they have to be compiled or exported to a file?


  • Module Developer

    Do you have the master or develop branch? I noticed this issue on the develop branch but “ipWhitelist: []” works for me on the master branch without issues.


  • Module Developer

    @rcollie I’m on develop branch and I’m using this to be able to access the mirror from anywhere (inside my network). I had to add the “address: “0.0.0.0”.” some time ago… :)

    var config = {
    	port: 8080,
    	ipWhitelist: [],
    	address: "0.0.0.0",
    ...
    

    Try it… :)



  • I am having the same issue as op and the last post doesnt help. Whenever I change the white list to anything other then default i just get a blank screen with MM



  • I’m not running the dev.

    I also tried what you suggested Snille with no change.



  • Alright… Well… It makes no sense (not that it has thus far anyway) but I was playing with different configurations of ipwhitelist today, and all of the sudden

    var config = {
    		port: 8080,
    		ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.0/28", "::ffff:192.168.2.0/28", "::ffff:192.168.3.0/28", "192.168.2.219"],
    

    worked. The computer I’m working from is the last IP. Literally changed nothing else.

    As far as I can figure just adding mine the the end of the default, for some reason works. Changing anything else (tested by changing it a few more times before coming back to this) broke it again. So this is literally the only way I can get it to work. Which… makes absolutely no sense.

    I’m not going to question it anymore at this point. Just enjoy the fact that its working.

    Maybe this will do something for you too @pingywon Just replace the last IP with your own.



  • I have come to the same conclusion on my own today. added the single ip of my work station and was able to get access. This works for now, but it is not a long term solution. I installed MMM-admin-panel and want to able to access the mirror from pretty much any ip inside my network.

    Im going to do some more testing on monday…but im afraid I might have to add every darn IP in my internal DHCP scope just to not have to worry about it.

    I agree it makes NO SENSE! :)

    In the meantime let me know if you come up with any other developments.

    Thank you



  • @Snille When I try this, the log stopped at this point:

    0|mm | Connecting socket for: MMM-Fuel
    0|mm | Starting module helper: MMM-Fuel
    0|mm | Sockets connected & modules started …
    0|mm | Launching application.
    0|mm | Access denied to IP address: 0.0.0.0/0


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.