Display works on remote computer, but not attached monitor



  • Setup version info
    Pi version: Raspberry Pi Model 3B
    OS: Raspbian Jessie Linux
    MM version: 2.1.2
    Installation style: Automatic

    Problem description
    I am not getting any errors. My entire display looks perfect when I connect from another computer which is on the whitelist, but the monitor attached to the pi just goes black whenever I start MM (I usually do it over SSH but starting with a keyboard plugged into the pi has the same result).

    Using DISPLAY:=0 before npm start does not resolve the issue. Switching back the sample config does not resolve the issue.

    IP Whitelist contains [“0.0.0.0”,“127.0.0.1”, “::ffff:127.0.0.1”, “::1”,“localhost”], so I don’t think that’s the problem (also no “Access Denied for IP 127.0.0.1” errors when it starts)

    This did not happen before I updated to 2.1.2, I was using 2.1.1 before. I updated node, npm, and Raspbian to the latest versions and no luck.

    Anyone have any ideas? It’s got to be something minor since everything renders properly on other devices that connect. I would appreciate any and all info!

    A separate issue I want to document because my googling found no answer:
    I got the following error after turning on the Pi and trying to start MM over SSH:
    Invalid MIT-MAGIC-COOKIE-1 keynpm
    You need to log into the Pi before starting MM over SSH. Apparently, most people are smart enough not to run into that but I want to find this thread next time I forget and have to google it.



  • It looks like this might be a MM-2.1.2 issue.

    I backed up my files, did a clean Raspbian install, installed MM-2.1.2, and ran the sample config file and got the exact same black screen. I downloaded the 2.1.1 release and both the sample and my custom config.js worked as expected. I didn’t see any github issues created for this, but I find it bizarre that I ran the same install script as everyone else and get this weird error.

    The only thing I did that I didn’t see in the tutorial was a few sudo npm install commands for jsonlint, colorguard, and coffeescript, then electron re-install once those were fixed. Sticking with 2.1.1 unless anyone has any ideas.



  • @mpvoss I ran into the same issue and it took me some time to figure it out. I’ve no idea how this happened but something changed my main.css. All modules were working just fine but were displayed “out of bounds”. I tried to show notifications on my screen and could see a little corner of it which got zoomed in and out and rescaled multiple times. I’m not sure if the main.css was the only problem but now it works just fine again on MM-2.1.2 on my Raspberry Pi Model 3B.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.