Help with showing todoist tasks?



  • So I thought I had this setup correctly, but none of my list are showing. Not sure what is going wrong, but the header “Todoist” is showing as shown in the screenshots. Can anyone help with this?

    this is in my config:
    2_1507843455124_todoist3.PNG

    I tried using both the client ID and the client secret. are these the api keys I am after?
    1_1507843455124_todoist2.PNG

    You can see the title on upper right with no tasks shown below:
    0_1507843455124_todoist1.PNG

    Been struggling with this for a bit. Thanks much.



  • Go to settings then integrations on the todoist website. You’ll find your api token there.



  • Thanks. Is that all that seems wrong?



  • @devtech8 Everything else seem fine.



  • put your lists in
    " "
    like this:

    lists: ["2163440886", "2162058078"]
    

    For troubleshooting, just use one list, if that works then, add the second.



  • @barnosch and @d3r - something seems messed up and nothing is going right with this. Tried quite a few variances.

    For some reason, I had it as lists: but I see in the repo for the project that it lists as projects:. So toyed around between the both of them with 1, 2, and 3 projects and creating test tasks. The config says the “projects” look a certain way in the URL with the number being after “%2F”. So in my case for 1 project, this screenshot:

    0_1507876269348_Capture.PNG

    So now my code in the config should be:

    {
    	module: 'MMM-Todoist',
    	position: 'top_right',	// This can be any of the regions. Best results in left or right regions.
    	header: 'Todoist test', // This is optional
    	config: { // See 'Configuration options' for more information.
    		  accessToken: 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
    		maximumEntries: 60,
    		interval: 60,
    		lists: ["2162058078"],
    		fade: false
      }
    },
    

    I am using the correct API key as noted from a previous response.

    If I look via dev tools at the page, here is a snapshot:

    0_1507876609146_Capture2.PNG

    But still, the best I can get is just the title showing up. Further thoughts please?

    Thanks much.



  • This one works for me.

    {
    		module: 'MMM-Todoist',
    		position: 'top_left',
    		header: "To Do", 
    		config: {
              		accessToken: 'blablablae0fa5611c30blablablablablabla',
    			maximumEntries: 20,
    			interval: 600,
    			lists: [ "2157759361" ],
    			fade: false,
          			}
    		}, 
    

    the %2F must be subtracted, correct.

    Did you install all the dependencies of the module with
    "npm install" within the “modules/MMM-todoist” folder ?



  • something else i mentioned.
    As i remember, there was some issues, Todoist was not showing something, like in your case.

    I never had the problems and i am on an very old version (jan 9)

    pi@pi3:~/MagicMirror/modules/MMM-Todoist $ git show
    commit 155ffe4d49bd8af59ab8bb0736c3ad756c0515d6
    

    (btw. not sure, if this is correct, like i did it, to see the installed version)

    Maybe @cbrooker has a idea for your problem.



  • @devtech8 Just remembered there was something else too.
    Did you take a look at this?
    https://github.com/cbrooker/MMM-Todoist/issues/16



  • That issue @d3r mentioned was the problem. It now displays just fine. Thanks for the help!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.