"moment npm package" causes black screen after npm start



  • Hello,

    I must be doing something very wrong.
    I followed the howchoo guide and did every step, except for 8.
    I also installed it manually since the automatic one wasn’t working for me.

    I’ve done all of my updates and upgrades and what-not but whenever I run
    DISPLAY=:0 npm start I get no errors, but the screen is just black.
    I’m using the provided config files with no modifications. Pulled from Master.

    //Update:

    I found out that this is the error that is causing it
    0_1508402507611_8e2dbef2-4b7e-4f6b-985c-e830050ed86c-image.png

    I basically get a ton of “Failed to load resource” errors and these cause this one to happen on a loop:
    0_1508402577780_31fbc48b-be84-4ad6-bdb2-56b2489ddbac-image.png

    I reinstalled moment, but the error still happens.



  • This post is deleted!


  • Solved the issue by simply running npm install in the vendor folder.

    Found thanks to this issue

    Thought I’d share the solution so maybe noobs like me can use it in the future.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.