MMM-Assistant Error Node module version



  • Hi !

    I’m trying to setup the MMM-Assistant module. I followed the wiki install process but at the end I have an error in my console and I can’t launch the mirror.

    Here is the error;

    WARNING! Could not load config file. Starting with default configuration. Error found: Error: The module '/home/pi/MagicMirror/modules/MMM-Assistant/node_modules/speaker/build/Release/binding.node’
    was compiled against a different Node.js version using
    NODE_MODULE_VERSION 48. This version of Node.js requires
    NODE_MODULE_VERSION 54. Please try re-compiling or re-installing
    the module (for instance, using npm rebuild ornpm install).

    I tried the npm rebuild, npm install, delete the node_modules folder and the npm install again, but I still have this error.

    Thanks a lot for your help !



  • hi,

    got the same error here today. did you figure out how to solve this?

    Thanks


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.