MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MMM-MirrorMirrorOnTheWall Clarification

  • Hello everyone. I just had a question about this module. I see that in order for this to work Alexa and the MirrorMirrorOnTheWallSkill needs to be installed. But what module of Alexa do i use? I see there is MMM-Alexa, MMM-awesome-alexa and MMM-AlexaPi. Which one do i use? or is it a different one completely?

  • @naem209
    Wish I would have an answer to this question. I tried to install a working alexa version which controls the magicmirror via voice for a week.

    Here is what I’ve found:

    Try this Alexa C++ sample app:


    The install takes at least 3 hours, but it’s almost automated, after that install the MirrorMirrorOnTheWallSkill on your PI home directory - not in Downloads or Documents use Pi root! Install the the necessary apps without using sudo.
    The Google Api and the Youtube API should be different. Make a project for each api. The provided google tutorial is old, but you can find a direct link in the youtube comments.

    When asking the mirror to show You videos, the videos will start, but You can’t close them because the mirror is not listening. So when Alexa speaks, you can’t interrupt her.

    Ask for Snow White pictures:)

    Watch out for the mirrormirror.js file, add Your IOT id to the file:

     keyPath: __dirname + "/certs/MagicMirror.private.key",
        certPath: __dirname + "/certs/MagicMirror.cert.pem",
        caPath: __dirname + "/certs/root-CA.crt",
        clientId: "MirrorMirror" + (new Date().getTime()),
        region: "us-east-1",
        host: ""

    Set the location to US east, Virginia.

    Test your skill before using it, if it not responds it will not work with Your mirror anyway.

    Hope it helps. If not comment here, I’ll help.

  • @Skoo Hi there i have AlexaPi working perfectly and i have tried to follow the instructions for MirrorMirrorOnTheWall to the T however i get a Lamda error if i test there and when i test at the Alexa stage at the end i also there was a problem with your response and just Null on the right… no How can i help you my queen… i am baffled i am 100 % sure i am not making any mistakes from what is written in the instructions (obviously i am or it would work) and i have tried a clean install 3 times
    What can i do
    where do i start the troubleshooting??
    The error on Lamda test always has to do with “aws-iot-device” on node-modules
    check out my other link for more info here

    Any help will be greatly appreciated

  • Project Sponsor Module Developer

    Well the real issues lies in the instructions most of the time. I have found for novice users following complicated instructions can be very difficult.

    It’s always easy for the developer…they wrote it so they understand it.

    When I write a module I try to make the instructions read like it’s the first time anyone has ever tried to install one…very basic with explanations.

    There seems to be a HUGE disconnect between programmers and novice users…people are expected to just understand and they don’t. Assumption is the mother of all F ups…

    I’ve tried most of the voice modules here and I’ve had a LOT of difficulties getting them to work myself.

  • Exactly …I made some progress last night and found out that it needed a iot-endpoint which should go in the instructions of the MirrorMirrorOnTheWallSkill somewhere before the start of part 3… that MirrorMirror.js file should be edited to add iot endpoint that you get from Aws Iot-Core site at the bottom left if you click on settings, than zip them in Archive folder and upload them to Lambda.
    Another thing or two that are missing from the instructions, on the MM module part now, of MirrorMirror is that a “npm install” is needed after cloning the module …also the key path for the certificates needs to be explained better for non coders on what the proper syntax is on how to do that.
    Now the Alexa part works, however its not doing what it is supposed to be doing and for that i do not know where to start troubleshooting after it says Hello my Queen (lol me a queen hahaha) when you ask her to preform any task related to that skill such as turn on and off a module such as compliments or displaying any video it says there is a problem with your skill try again later …so no idea where to start on that???

  • Project Sponsor Module Developer

    @richland007 I haven’t tried to build any Alexa skills as of yet [I have 2 real Alexas lol].

  • @richland007 Any luck with this? I’m working through the same issue right now. I get “Hello Queen” response but anything after that is “Error with Response”

Log in to reply