MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Custom resolution



  • Hi,

    I am using magic mirror on RPI3. But i need to set up resolution 1024*600 becuse i am using tft display with that resolution. How can i change resolution to this?



  • Usually the OS in the background should autodetect the resolution of the TFT.
    If not and you are already autostarted the MM system, try to

    pm2 stop
    

    via SSH
    and try to change the resolution manually on the running Linux.
    (Maybe you can add temporarily a mouse to the pi or log in remotely via VNC)
    VNC can be enabled via SSH within the console (sudo raspi-config)



  • I will try, but problem is that resolution is not standard that is listed on this Linux, resolution that i need is 1024x600alt text



  • From the official Raspberry site:
    Video mode

    Custom mode
    
    If your monitor requires a mode that is not in one of the tables above, then it's possible to define a custom CVT mode for it instead:
    
    ***please note, need to ad a blank space before the bracket, in order to display it here correctly***
    hdmi_cvt=< width> < height> < framerate> < aspect> < margins> < interlace> < rb>
    
    Value 	Default 	Description
    width 	(required) 	width in pixels
    height 	(required) 	height in pixels
    framerate 	(required) 	framerate in Hz
    aspect 	3 	aspect ratio 1=4:3, 2=14:9, 3=16:9, 4=5:4, 5=16:10, 6=15:9
    margins 	0 	0=margins disabled, 1=margins enabled
    interlace 	0 	0=progressive, 1=interlaced
    rb 	0 	0=normal, 1=reduced blanking
    
    Fields at the end can be omitted to use the default values.
    
    Note that this simply creates the mode (group 2 mode 87). In order to make the Pi use this by default, you must add some additional settings. For example, the following selects an 800 × 480 resolution and enables audio drive:
    
    hdmi_cvt=800 480 60 6
    hdmi_group=2
    hdmi_mode=87
    hdmi_drive=2
    
    This may not work if your monitor does not support standard CVT timings.
    


  • Thanx i have set and now work normaly.