Troubles upgrading



  • Hi all,
    Just setting up my second magic mirror, cloned the img on my SD card from my working mirror and all works great.
    Original install was following the raspberry pi 0 how to guide.

    Only thing I’m struggling with is how to update magic mirror.

    Original command that I think installed magicmirror was bash -c “$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)”

    I’ve tried sudo apt-get update and sudo apt-get upgrade which did a whole bunch of stuff, seemed to complete successfully but I still have the MagicMirror2 update available message on the screen saying I’m 86 commits behind. (just realised I think those two commands update the system not magicmirror).

    Also tried git pull, that gives the error: The following untracked working tree files would be overwritten by merge:
    package-lock.json
    vendor/package-lock.json
    Please move or remove them before you can merge
    Aborting.

    Apologies if this is something really simple but any advice would be greatly appreciated.

    Thanks
    Noel



  • @noelandrews That’s correct.

    apt-get update        # Updates your system packages list to see what need to be upgraded 
    sudo apt-get upgrade  # Actually performs the update of the system packages
    
    cd ~/MagicMirror
    git pull              # update your MagicMirror
    

    The packages is not really code, just version info etc. Just delete and pull.

    PS. Make sure to backup you config.js file and other personalized module changes you have done, if any.



  • Worked perfectly thanks E3V3A 🙂

    Now to find out what improvements I can take advantage of in the new version!



  • @noelandrews No prob. Always glad I could be of help to someone else. So many have already helped me with all my own stupid questions…