MMM-Assistant (Dev Updates)



  • I’ve just pushed all new updates to the MMM-Assistant. GA and MM control now works. Please test.

    I would also like to implement the Alexa service so I could always use some help for that.

    Cheers,
    E:V:A



  • @E3V3A gonna give this a try tomorrow. So far i’ve not had much luck with the awesome-alexa module.it shows to be working but i never hear a response, i have had a google assistant working using googles test code but not with the google assistant module… it would perform oddly



  • Just to have it said.

    The biggest challenge for any new (voice) user, is to correctly setup:

    • the ALSA audio (if you haven’t used it before)
    • the Google/Alexa developer accounts.

    I’m working on a descent HowTo, but I find it very boring, so I keep putting it off… Anyway, I’ve made some changes, so please contact me if you encounter any problem, and I’ll try to walk you through.



  • @E3V3A yeave ive gotten all the account setup properly, and when im goging through the google api setup and it has you test the assistant it would work just fine but when i would load the other assistant module, the assistant would hear my quest and not respond to it until i said the hotword again… was very odd



  • @hnperkins said in MMM-Assistant (Dev Updates):

    @E3V3A … but when i would load the other assistant module, …

    What do you mean the “other assistant”?
    Are you trying to run 2 different voice modules at the same time?
    (You can’t do that without a crazy complicated ALSA config.)



  • @E3V3A not at the same time no, i originally was trying to get awesome-alexa running but gave up on it for a while due to not being able to get a proper response for a refresh token so i tried the mmm-googleassistant module which seemed to work until i ran the python script with the module to use the assistant and when i would say a command you could see in the console the script pick up the command but then not answer until i said the hot word again, the creator of the module told me there was nothing wrong and closed my ticket on it so i have not tried to use any of the g assistant modules since then



  • @hnperkins I see.
    Yeah, I got awesome-alexa working after a load of PITA useless docs. So I know how to make it work, but then it would suddenly stop responding without any signs at all. No logs, no errors, no nothing. So I gave up…



  • @E3V3A yeah thats kind of where im at now, it acts like its going to respond but then nothing ever happens. and this morning its now saying my version of the module is out of date but i did a git pull and said it was up to date so idk anymore.



  • @hnperkins Don’t update voice modules!! Unless you know exactly what you are dong. Because you will likely overwrite in-code settings. Since many modules depend on editing and hard coding the API keys in the code or other files.



  • @E3V3A i back up the module folder before i do any updates just in case i do run in to that issue lol