MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

MM installation error by electron / arm64



  • I’m sorry first.
    I do not speak English well.
    That’s why we use google translation.

    I first installed MM on the artik 530 and odroid ux4.
    The MM installation succeeded and worked well on these two devices.

    But I tried to install MM again in artik 710s, but I can not …

    In the same way, I installed ubuntu 16.4 server on VMware workstation and MM is working.

    I think the artik 710s is due to arm64.

    [root@artik MagicMirror]# grep . /etc/*-release
    /etc/lsb-release:DISTRIB_ID=Ubuntu
    /etc/lsb-release:DISTRIB_RELEASE=16.04
    /etc/lsb-release:DISTRIB_CODENAME=xenial
    /etc/lsb-release:DISTRIB_DESCRIPTION="Ubuntu 16.04.4 LTS"
    /etc/os-release:NAME="Ubuntu"
    /etc/os-release:VERSION="16.04.4 LTS (Xenial Xerus)"
    /etc/os-release:ID=ubuntu
    /etc/os-release:ID_LIKE=debian
    /etc/os-release:PRETTY_NAME="Ubuntu 16.04.4 LTS"
    /etc/os-release:VERSION_ID="16.04"
    /etc/os-release:HOME_URL="http://www.ubuntu.com/"
    /etc/os-release:SUPPORT_URL="http://help.ubuntu.com/"
    /etc/os-release:BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
    /etc/os-release:VERSION_CODENAME=xenial
    /etc/os-release:UBUNTU_CODENAME=xenial
    [root@artik MagicMirror]# uname -m
    aarch64
    [root@artik MagicMirror]# getconf LONG_BIT
    64
    [root@artik MagicMirror]# dpkg -s libc6 | grep Arch
    Architecture: arm64
    Multi-Arch: same
    [root@artik MagicMirror]# npm -v
    5.8.0
    [root@artik MagicMirror]# node -v
    v8.11.1
    
    [root@artik MagicMirror]# npm install
    
    > electron-chromedriver@1.7.1 install /root/MagicMirror/node_modules/spectron/node_modules/electron-chromedriver
    > node ./download-chromedriver.js
    
    /root/MagicMirror/node_modules/spectron/node_modules/electron-chromedriver/download-chromedriver.js:16
      if (error != null) throw error
                         ^
    
    Error: Failed to find Electron v1.7.0 for linux-arm64 at https://github.com/electron/electron/releases/download/v1.7.0/chromedriver-v1.7.0-linux-arm64.zip
        at Request. (/root/MagicMirror/node_modules/nugget/index.js:169:61)
        at emitOne (events.js:116:13)
        at Request.emit (events.js:211:7)
        at Request.onRequestResponse (/root/MagicMirror/node_modules/request/request.js:1068:10)
        at emitOne (events.js:116:13)
        at ClientRequest.emit (events.js:211:7)
        at HTTPParser.parserOnIncomingClient [as onIncoming] (_http_client.js:551:21)
        at HTTPParser.parserOnHeadersComplete (_http_common.js:115:23)
        at TLSSocket.socketOnData (_http_client.js:440:20)
        at emitOne (events.js:116:13)
    npm WARN grunt-stylelint@0.10.0 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
    
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! electron-chromedriver@1.7.1 install: `node ./download-chromedriver.js`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the electron-chromedriver@1.7.1 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /root/.npm/_logs/2018-04-05T06_42_45_454Z-debug.log
    

    https://github.com/electron/electron/releases/tag/v1.7.0
    When I checked here, I could not find the arm64.

    My simple idea is that you do not have https://github.com/electron/electron/releases/download/v1.7.0/chromedriver-v1.7.0-linux-arm64.zip

    https://github.com/electron/electron/releases/tag/v1.8.0
    There is an arm64 file since version 1.8.

    I want to modify it to be installed with electron 1.8 or later version, but I do not know how.

    help me plz