MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Display not stretched to fit monitor size



  • I guess this is a hardware question, sorry I am totally new to Magic Mirror so please bear with me.

    I have the interface/display up and running, but it does not expand to fit the monitor size. Like, I have blank space on all 4 sides of the screen (even before the bezels. I’d estimate there’s an extra 5-10% on each side, so it doesn’t look as good as it probably could right now.

    I’ve tried utilizing the “zoom” function in config.js, but to no avail. Any ideas on where I can start to fix this? Thanks!


  • Module Developer

    I would also like to know how to set a zoom level in config.js or in css or anywhere it would work to zoom in automatically when loading…



  • @justjim1220 OK, I’ve been banging my head on this, and it turned out to be two different things:

    1. I had to exit MagicMirror to get back to the Raspbian desktop, and go into Preferences for display. There was an underscan box checked, so I unchecked that. After reboot, the screen was right-justified, with only a gap on the left.

    2. Another post (https://forum.magicmirror.builders/topic/5318/remove-margins) tipped me off to edit the main.css to remove the margin (set to 0ppx), and that’s gotten left, top, and right all set. There’s still some space at the bottom, but it is past my bedtime. I’ll have to look at that in the morning.

    Maybe this could help for you as well, hopefully. Good luck!


  • Module Developer

    My issue isn’t with the margins.
    It’s with the resolution of the monitor…
    I’m using a 32" TV as a monitor on my older desktop, and all the modules are overlapping each other. If I zoom out about 8 or 9 times then it looks really good… But I’m getting tired of having to zoom it with every reload. I would like to just be able to set the zoom in the config or other settings. Or, maybe I just need a higher resolution TV???