MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

PLEASE HELP. Error: read ECONNRESET at TLSWrap.onread (net.js:602:25)



  • tried to run the bash command and the installation got stucked to this message
    can you guys help me step by step?
    I HAVE NO IDEEA ABOUT PROGRAMMING AND A STEP BY STEP TUTORIAL WILL SAVE MY LIFE.
    THANK YOU VERY MUCH

    **Cloning into 'MagicMirror'...
    remote: Counting objects: 277, done.
    remote: Compressing objects: 100% (246/246), done.
    remote: Total 277 (delta 37), reused 121 (delta 21), pack-reused 0
    Receiving objects: 100% (277/277), 421.09 KiB | 554.00 KiB/s, done.
    Resolving deltas: 100% (37/37), done.
    Cloning MagicMirror Done!
    Installing dependencies ...
    
    > uws@0.14.5 install /home/pi/MagicMirror/node_modules/uws
    > node-gyp rebuild > build_log.txt 2>&1 || exit 0
    
    
    > electron-chromedriver@1.7.1 install /home/pi/MagicMirror/node_modules/spectron/node_modules/electron-chromedriver
    > node ./download-chromedriver.js
    
    
    > electron@1.7.13 postinstall /home/pi/MagicMirror/node_modules/electron
    > node install.js
    
    /home/pi/MagicMirror/node_modules/electron/install.js:48
      throw err
      ^
    
    Error: read ECONNRESET
        at TLSWrap.onread (net.js:602:25)
    npm WARN grunt-stylelint@0.10.0 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
    
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! electron@1.7.13 postinstall: `node install.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the electron@1.7.13 postinstall script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2018-04-15T23_48_40_173Z-debug.log
    Unable to install dependencies!
    pi@raspberrypi:~ $**