Midori white screen (Raspberry Pi Zero W)



  • Hi guys,

    I try to put MagicMirror on my Raspberry Pi Zero W (not enough space in the mirror for a Pi 3b). I set everything up like in the following post: How I got my Magic Mirror working on a Raspberry Pi 0 (zero)

    Except:

    1. I modified many things on the MagicMirror 6 month ago (css, some modules), why I didn’t updated it. I have an older version, that works on my PC. So I had to move this file on the Pi.
    2. Npm and node didn’t really work (npm i dind’t install everything), why I coudn’t use /sudo dpkg -i node_latest_armhf.deb. I don’t know anymore how I did it, but I installed node 8.11.1 and npm 6.0.1.

    On my PC the MagicMirror works fine (with node serveronly). Every module works perfectly. When I change index.html with a h1 and a simple text i can see it. But when i use the MagicMirror, there is a fullscreen white page.
    Autostart, fullscreen and “hide curser” works, it’s just the mirror that’s not working.

    Today i tried to npm i again (hoped it would maybe work) --> got some errors because of electron-chromedriver. I installed the chromedriver manually and moved it in the node_modules.

    Now I’m working some weeks on this problems, but don’t know why it’s not working. Do you have any idea?

    Thanks



  • @meyraa midori has problems with es6. did you try to deactivate all modules and activate one by one again to see if there is a module that is using es6?



  • @strawberry-3-141 thank you for your answer. I deactivated (removed from the config) each module except the clock module. But sadly nothing changed. Then i updated my MagicMirror and made a new config, but sadly that didn’t changed anything.
    On my PC it works, however i got the following error

    Whoops! There was an uncaught exception...
    { Error: socket hang up
        at createHangUpError (_http_client.js:331:15)
        at Socket.socketCloseListener (_http_client.js:363:23)
        at emitOne (events.js:121:20)
        at Socket.emit (events.js:211:7)
        at TCP._handle.close [as _onclose] (net.js:554:12) code: 'ECONNRESET' }
    

    I will look if there is some other ES6 features, but wouldn’t more people have the same issue when it would be in the default modules?



  • Today I removed all arrow functions and replaced all “let” and “const” with var. But sadly this is not helping too. I don’t know if there is another browser i could use or use babel.



  • @strawberry-3-141 Ok now i solved it. I just installed chromium-browser and did everything with it. It works with the ES6 too. I reversed my changes.

    Thank you for your answer. I struggled a long time. Without your hint i wouldn’t find it soon.



  • @meyraa from what i heard in the forum here, the users of the pi zero reported all that midori is the only browser on this pi that has no performance issues. The advantage of the chromium browser is that it is completely compatible, as electron internally uses the chromium project.


 

229
Online

6.0k
Users

4.5k
Topics

37.2k
Posts