MagicMirror stays black, but loading from another browser (Windows, Android) works

  • trying your script or chvt 6 [or 7] manually does result in this error:

    Konnte keinen Dateideskriptor finden, der auf die Konsole verweist.

    The monitor is turning on correctly and I can see the background dark grey in the mirror, but it simply does not show the mirror. Maybe it somehow has multiple desktops defined and just showing the wrong on hdmi output…

  • Module Developer

    @andurii Yep, that definetly sounds like your monitor just went sleeping.

  • Module Developer

    @andurii I get the same error message “Couldn’t get a file descriptor referring to the console” but the monitor turn on… 🙂

    I have tow desktops as well, the Mirror shows up on one of them… I can use (in VNC) CTRL + ALT + Right or Left arrow key to switch between virtual desktops.

  • that only works for PI devices where tvservice command exists… I run MM on an ODROID so, that doesn’t help…

    I also use an EnergyStar TV, which freaks out when the video input signal is cut and then powers off after 15 minutes…

  • I did use CTRL + ALT + RIGHT or LEFT, but that didn’t helped either. Only change was that in the middle of the VNC-session was a small blue notification saying Desktop 1 so I suppose I have only one virtual desktop active.

  • well something strange I noticed… (don’t know if that’s related)
    My Desktop used to be PIXEL I think (this nice road wallpaper and menu bars at the top. Now it looks like it is running Openbox. I don’t know how this happened, but it was not intended by me. Was that changed in the newest version because of my upgrades?