MMM-Pages not able to get it to be consistent all modules on page one



  • Hello All
    Looking for some help I have an issue with Pages that I have been fighting for three days now.
    First I’m new to MagicMirror.
    I have dad some experience with Raspberry Pi before but not to much.
    Running a Raspberry Pi 2 B
    MagicMirror 2.4.1

    The issue is Pages is putting ever thing on the first page and neve switching.
    If I get Pages to work like I have it in the config file it will only stay that way for that session.
    I still developing the system so I’m shutting down the Pi at night.
    If I have it working and shut down the system and restart Pages will work.
    But if I shut down the system for overnight then the next day it will be confused again
    And all the modules are on the first page again.

    I have looked at the log file and don’t see anything out of place that I know of.
    Here is my config.js file.

    Any help would be outstanding and thank you.

    var config = {
    	address: "0.0.0.0", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: [], // Set [] to allow all IP addresses was "127.0.0.1", "::ffff:127.0.0.1", "::1","::ffff:10.19.57.64/26"
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	language: "en",
    	timeFormat: 12,
    	units: "imperial",
    
    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    		        module: 'MMM-pages',
    	        	config: {
    	                modules:
    	                    [["calendar","weatherforecast","newsfeed"],
    	                     ["MMM-NOAA","MMM-PushBulletNotifications","MMM-SystemStats","mmm-systemtemperature","MMM-NetworkConnection"],
    				["calendar"]],
    	               	excludes: ["clock","currentweather","compliments","MMM-page-indicator"],
    			animationTime: 8000,
    			rotationTime: 20000			
    	        	}
        		},
    		{
    			module: "clock",
    			position: "top_left"
    		},
    		{
    			module: 'MMM-SystemStats',
    			position: 'top_left', // This can be any of the regions.
    			classes: 'small dimmed', // Add your own styling. Optional.
    			config: {
    				updateInterval: 10000,
    				animationSpeed: 0,
    				align: 'right', // align labels
    				//header: 'System Stats', // This is optional
    			}
    		},
    		{
    			module: 'mmm-systemtemperature',
    			position: 'top_left',	// This can be any of the regions.
    			classes: 'small dimmed', // Add your own styling. Optional.
    			config: {
    				// See 'Configuration options' for more information.
    			}
    		},
    
    		{
    			module: "calendar",
    			header: "US Holidays",
    			position: "top_left",
    			config: {
    				calendars: [
    					{
    						symbol: "calendar-check-o ",
    						url: "webcal://www.calendarlabs.com/templates/ical/US-Holidays.ics"
    					}
    				]
    			}
    		},
    		{
    			module: 'MMM-PushBulletNotifications',
    			header: 'Notifications',
    			position: 'top_left',	// This can be any of the regions.		
    			config: {
    				// See 'Configuration options' for more information.
    				accessToken: "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx", //PushBullet API Access Token
    				numberOfNotifications: 3,
    				filterTargetDeviceName: "",
    				showPushesSentToAllDevices: true,
    				onlyAllowCommandsFromSourceDevices: [],
    				fetchLimitPushBullet: 50,
    				showPushes: true,
    				showPushesOnLoad: true,
    				showDismissedPushes: true,
    				showMirroredNotifications: true, 
    				showSMS: true,
    				showMessage: true,
    				showIcons: true,
    				showDateTime: true,
    				localesDateTime: 'nl-NL',
    				playSoundOnNotificationReceived: true,
    				soundFile: 'modules/MMM-PushBulletNotifications/sounds/new-message.mp3',			
    				maxMsgCharacters: 70,
    				maxHeaderCharacters: 22,
    				showModuleIfNoNotifications: true,
    				noNotificationsMessage: "No new notifications",
    				debugMode: false,
    			}
    		},
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "Newport,US",
    				locationID: "4143871",  //ID from http://www.openweathermap.org/help/city_list.txt
    				appid: "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
    				showHumidity: true
    			}
    		},
    
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "",
    				locationID: "4141363",  //ID from http://www.openweathermap.org/help/city_list.txt
    				appid: "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
    				showRainAmount: true,
    				colored: true
    			}
    		},
    		{
        			module: 'MMM-NOAA',
    			position: "top_right",
        			config: {
    
    				apiKey: "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",    // https://www.wunderground.com/weather/api  select the middle plan... 
    				airKey: "xxxxxxxxxxxxxxxx"    // IF you want Air Quality Index
    			}
    		},
    		{
    			module: "compliments",
    			position: "lower_third"
    		},
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "Fox News",
    						url: "http://feeds.foxnews.com/foxnews/latest",
    					},
    				],
    				showSourceTitle: true,
    				showPublishDate: true,
    			}
    		},
    		{
    		    	module: 'MMM-NetworkConnection',
        			position: 'bottom_bar',
        			config: {
        				}
    		},
    		{
    		        module: 'MMM-page-indicator',
    		        position: 'bottom_bar',
    		        config: {
    		            pages: 3,
    		        }
        		},
    		
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    
    

  • Module Developer

    @GeckospotNixie

    i think there is an bug in the latest version of MMM-pages, see Issues.

    I have the same behavior you described after updating MMM-pages today.

    I restored the folder MMM-pages from my backup to an older version and now it is working again.

    AxLED