MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MagicMirror quits without errors



  • Hey,

    a few days ago I upgraded to 2.5.0. I don’t know if it’s correlated, but I can’t exclude…
    This morning I noticed my Mirror showing the desktop and not the mirror interface. It seems to be in a restarting loop, but I don’t see any reason why. I also tried to start it manually without pm2, but I just said Launching application.and returned to the console. Has anyone an idea how to find the cause?

    Regards,
    Anduril

    pi@Spieglein:~ $ pm2 logs MagicMirror
    [TAILING] Tailing last 15 lines for [MagicMirror] process (change the value with --lines option)
    /home/pi/.pm2/logs/MagicMirror-out.log last 15 lines:
    0|MagicMir | No helper found for module: MMM-doomsDay.
    0|MagicMir | No helper found for module: MMM-forecast-io.
    0|MagicMir | All module helpers loaded.
    0|MagicMir | Starting server on port 8080 ...
    0|MagicMir | You're using a full whitelist configuration to allow for all IPs
    0|MagicMir | Server started ...
    0|MagicMir | Connecting socket for: MMM-Remote-Control
    0|MagicMir | Starting node helper for: MMM-Remote-Control
    0|MagicMir | Connecting socket for: updatenotification
    0|MagicMir | Connecting socket for: MMM-DVB
    0|MagicMir | Starting module helper: MMM-DVB
    0|MagicMir | Connecting socket for: calendar
    0|MagicMir | Starting node helper for: calendar
    0|MagicMir | Sockets connected & modules started ...
    0|MagicMir | Launching application.
    
    /home/pi/.pm2/logs/MagicMirror-error.log last 15 lines:
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    0|MagicMir | libGL error: MESA-LOADER: failed to retrieve device information
    
    pi@Spieglein:~/MagicMirror $ DISPLAY=:0 npm start dev
    
    > magicmirror@2.5.0 start /home/pi/MagicMirror
    > sh run-start.sh "dev"
    
    Starting MagicMirror: v2.5.0
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: MMM-Remote-Control
    Initializing new module helper ...
    Module helper loaded: updatenotification
    Initializing new module helper ...
    Module helper loaded: MMM-DVB
    No helper found for module: clock.
    Initializing new module helper ...
    Module helper loaded: calendar
    No helper found for module: compliments.
    No helper found for module: MMM-doomsDay.
    No helper found for module: MMM-forecast-io.
    All module helpers loaded.
    Starting server on port 8080 ...
    You're using a full whitelist configuration to allow for all IPs
    Server started ...
    Connecting socket for: MMM-Remote-Control
    Starting node helper for: MMM-Remote-Control
    Connecting socket for: updatenotification
    Connecting socket for: MMM-DVB
    Starting module helper: MMM-DVB
    Connecting socket for: calendar
    Starting node helper for: calendar
    Sockets connected & modules started ...
    Launching application.
    pi@Spieglein:~/MagicMirror $
    


  • I’m having the exact same problem - just started this morning when I tried a restart. I’ve tried updating Electron, dumping and rebuilding the npm cache, as well as re-setting up pm2, but no luck so far.

    Only difference is when I try npm start dev, it goes all the way through to Launching Application and then hangs (I need to power cycle to be able to type anything).

    Please let me know if you manage to figure it out!



  • It seems to be working fine again here… I don’t have any idea what has happened. But I will keep an eye out for further problems.



  • @chief said in MagicMirror quits without errors:
    I’m having the exact same problem
    Hey I’m french
    J’ai le même probléme sur Raspberry 2 installation nouvelle de Raspbian Stretch , MagicMirror 2.5 a demarré après la première installation mais après redémarrage , il affiche le bureau .
    Ma précèdente installation Stretch avec la version 2.2 s’affichait normalement .
    Avez vous une idée ?
    Thanks for your help .