MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MagicMirror not showing, even though pm2 says it's online



  • I have tried this 3 times – brand new raspbian install, ran the magicmirror2 installation script, enabled pm2, once it’s completed, magicmirror starts great! I can stop/start via pm2, edit the config, make changes, mirror comes back up. Upon my first reboot, magicmirror never starts again. I run pm2 start MagicMirror, pm2 says it’s online, but nothing ever appears.

    Looking at pm2’s MagicMirror-error.log, I see
    Error: ENOENT: no such file or directory, open 'package.json'

    I tried running pm2 start MagicMirror from /home/pi/MagicMirror and /home/pi, with the same results.

    I actually made another magicmirror 2 weeks ago using the same raspbian build and same pi model (latest), no issues whatsoever, so not sure what’s going on this time around? Are there other logs for me to look at to help diagnose the issue?

    any thoughts/suggestions/help would be greatly appreciated!

    update if I run npm start from the MagicMirror dir, it actually loads fine! Any thoughts as to what’s wrong with pm2?

    update2 I deleted the existing MagicMirror app in pm2 and created my own from scratch, following this guide: https://github.com/MichMich/MagicMirror/wiki/auto-starting-magicmirror, and it seems to work as expected now – not sure what was wrong w/the auto created MagicMirror app


  • Module Developer

    @jrinco11

    try npm rebuild