MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MagicMirror does not start anymore



  • Hello everyone,

    I am coming to you because of a problem that I can not solve.
    I rebooted my magic mirror and relaunched it. While everything was working correctly until now, it shows me a black screen.
    I started this one with the command npm start dev and it shows me the following error:

    pi@raspberrypi:~/MagicMirror $ npm start dev
    
    > magicmirror@2.5.0 start /home/pi/MagicMirror
    > sh run-start.sh "dev"
    
    Starting MagicMirror: v2.5.0
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    No helper found for module: calendar_monthly.
    WARNING! Could not load config file. Starting with default configuration. Error found: Error: Cannot find module 'valid-url'
    Loading module helpers ...
    No helper found for module: alert.
    No helper found for module: calendar_monthly.
    App threw an error during load
    Error: Cannot find module 'valid-url'
        at Module._resolveFilename (module.js:543:15)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
        at Function.Module._load (module.js:473:25)
        at Module.require (module.js:586:17)
        at require (internal/module.js:11:18)
        at Object. (/home/pi/MagicMirror/modules/default/calendar/node_helper.js:9:16)
        at Object. (/home/pi/MagicMirror/modules/default/calendar/node_helper.js:80:3)
        at Module._compile (module.js:642:30)
        at Object.Module._extensions..js (module.js:653:10)
        at Module.load (module.js:561:32)
    Whoops! There was an uncaught exception...
    { Error: Cannot find module 'valid-url'
        at Module._resolveFilename (module.js:543:15)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
        at Function.Module._load (module.js:473:25)
        at Module.require (module.js:586:17)
        at require (internal/module.js:11:18)
        at Object. (/home/pi/MagicMirror/modules/default/calendar/node_helper.js:9:16)
        at Object. (/home/pi/MagicMirror/modules/default/calendar/node_helper.js:80:3)
        at Module._compile (module.js:642:30)
        at Object.Module._extensions..js (module.js:653:10)
        at Module.load (module.js:561:32) code: 'MODULE_NOT_FOUND' }
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    Launching application.
    
    

    I made an update of my raspberry and made a npm install in the MagicMirror folder but that does not change anything.

    Could someone give me a track to solve this problem?

    Thanking you in advance,

    Regards,



  • Try npm install valid-url from the Magic mirror folder



  • @sdetweil

    Hello,

    Thank you for your answer.
    I tried install valid-urlbut it did not change anything.
    I solved the problem using a backup of the pi that I had (thankfully) done.
    I updated the pi and everything is working properly.
    this bug will definitely remain a mystery …

    Thank you for your help,
    Regards,


Log in to reply