MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

PIR Sensor Weirdness



  • I’ve installed and configured MagicMirror, and I’m using the MMM-PIR-Sensor module. I bought several PIR sensors in a lot from Amazon (https://www.amazon.com/gp/product/B012ZZ4LPM/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1), and I’ve tried each one of them to make sure my issue isn’t related to the sensor itself. I’m still not 100% convinced.

    The monitor turns off as expected after ~63 seconds (3 second delay on the PIR and 60 seconds in the config). Immediately upon turning off, a high signal is received by the Raspberry Pi. I’m constantly checking with “gpio read 3” and it reports 0 until the monitor is turned off, then immediately reports 1 for ~3 seconds.

    Is there some kind of interference going on, and if so, how can I stop it? I ask this because I have the PIR inside a box so it isn’t detecting motion/heat.

    Thanks for the help.



  • This post is deleted!


  • Hi @uatuba ,

    did you find a solution/reason for that? I have exactly the same problem with my Sensor.



  • Got it!

    I was wondering why the false positive signals come in a strict 60 second interval.

    The cause of the problem is the WiFi. The cables between the Raspberry and the PIR sensor acted like an antenna. The WiFi signal apparently caused a regular induction in it.

    I solved the problem by moving the cables to the other side of the Raspberry (as far away from the WiFi antenna as possible). I also wrapped them with aluminium foil. The problem has disappeared 🙂


Log in to reply