All modules auto hide, except currentweather



  • This may be a feature but I can’t find any info on it.

    I’m still preparing my MM, so my Pi 3B+ is hooked onto a spare monitor and sitting on my desk. All works well, but after some time, all modules disappear from view, except the (default) currentweather. I configured a hotword for Google Assistent, and activating this all modules come back to view.

    Also when my webcam recognizes my face, the default Calendar module comes up (exactly as I intended it). But the other modules stay hidden.

    The thing is: WHY do all modules hide, except one? As far as I can tell there is little reason for the default clock not to behave in exactly the same way, but it doesn’t. The other thing is: the hotword should only triggers Google assistant, so I don’t understand why it wakes all the other modules while the face recognition only triggers the calendar. What is happening and how do I control it?

    My settup:
    MMM-AssistantMk2
    MMM-Facial-Recognition-OCV3
    MMM-Hotword
    MMM-Hue-Lights


  • Module Developer

    @jck
    onIdle and onDetected features of MMM-AssistantMk2 make hiding/revealing modules. You can disable by configuration.
    Anyway, I don’t know about why currentWeather is not affected.



  • @sean thanks! So it is a feature! I can see what we could do with it, and now that I know where to look, I’ll put it to good use. I’ll dive into the currentweather code and try to find out why it behaves different.