MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

"Today" on default calendar module



  • Is there anyway that I can remove the “Today” and “at” whatever time an event is on the calendar? I only show events for the current day. I am not so busy that I need to display the event time from the calendar. After each event it says “Today at 5:30 PM”, or whatever time the event has from google calendar. I would only like to display the events. Is there a way to edit out the rest? I have two mirrors setup and I thought i edited the “Today” out of the calendar.js file, but now its back. It would just show 5:30 event time and not the Today. If the calendar event is an all day event, it wont show the time anyway, just the “Today”. Its still edited out of the calendar.js file, but it displays it anyway. I have searched all through the configs and I just dont understand it enough to figure it out. If someone could point me in the right direction where to look, I would appreciate it greatly.

    There is just so much potential here, but I am limited alot because I just cant wrap my head around this node.js stuff…

    Rob



  • I’d use this in my config.js for the calendar module’s config:

    dateFormat: "h:mm a", //  This sets the string to time only
    timeFormat: "absolute", // only shows times normally. 
    getRelative: 0, // lowers the limit for absolute time to zero - no relative. 
    urgency: 0, // makes sure it stays absolute.
    

    I do believe that changing the dateFormat to “H:mm” will go 24 hour.



  • @bkeyport , Thanks for working with me here…

    I added that to my config. It didnt change the display any. Other than the calendar url, the only options i have in my config are maximumEntries: “4” & maximumNumberOfDays: “1”. Making your modification had no affect on the display. I tried it on two different mirrors with the same result. I will try it with an event with a given time and see if it has an affect on that…

    Rob



  • odd… Here’s how I have mine configured, and it clearly changes things

    {
    			module: "calendar",
    			position: "top_right",
    			config: {
    				maximumEntries: 15,
    				maximumNumberOfDays: 90,
    				displaySymbol: false,
    				maxTitleLength: 30,
    				wrapEvents: true,
    				fetchInterval: 120000,
    				fade: false,
    				dateFormat: "M/D h:mm a",
    				fullDateEventDateFormat: "M/D",
    				timeFormat: "absolute",
    				getRelative: 0,
    				urgency: 0,
    				broadcastEvents: false,
    				hideOngoing: true,
    				excludedEvents: ["InOffice"],
    				dateEndFormat: "h:mm a",
    				calendars: [
    					{
    						symbol: "calendar",
    						url: "https://url", 
    					}
    					],
    				}
    		},
    


  • @bkeyport , I will give that a try and get back with you…



  • @bkeyport, I modified my config with your config and it removed the Today, just as I was looking for! Thank you for your help. I think where my problem may have been is instead of having all of the config options above the calendars section, right after the config braces, I had all of my options below the url line in the calendars section…

    When I saw your config layout, I was immediately suspicious of my config layout being the culprit…

    I had one mirror that was still displaying Today even though I edited the config just like the other one that was not displaying it… I ended up having to edit line 279 in the calendar.js file & removing the text “Today” from "timeWrapper.innerHTML = this.capFirst(this.translate("Today “));”

    That together does the trick! I thank you for your help!