MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

MONITORON on does not work in schedule



  • Hi,
    I’ve installed MMM-Remote-Control and MMM-ModuleScheduler. I basically want the MM to be off all night, it should then start up at 9:15, the monitor turn on at 9:30, then off at 11:30 and MM down at 11:45. The global_schedule works fine and the monitor shuts off correctly. However, the monitor does not come on in the morning. I can use the power on menu choice from the remote web page to turn the monitor on. It just won’t come on via the notification_schedule. Can someone suggest what is incorrect in my config.js entry?

    module: 'MMM-ModuleScheduler',
            config: {
    	    // Show all modules at 9:15 every day and hide at 11:45
    	   global_schedule: {from: '15 9 * * *', to: '45 23 * * *'},
                notification_schedule: [
                    // TURN THE MONITOR/SCREEN ON AT 09:30 EVERY DAY
                    {notification: 'REMOTE_ACTION', schedule: '30 9 * * *', payload: {action: "MONITORON"}},
                    // TURN THE MONITOR/SCREEN OFF AT 11:30pm EVERY DAY
                    {notification: 'REMOTE_ACTION', schedule: '30 23 * * *', payload: {action: "MONITOROFF"}},
                    // RESTART THE MAGICMIRROR PROCESS AT 2am EVERY SUNDAY
                    {notification: 'REMOTE_ACTION', schedule: '0 2 * * SUN', payload: {action: "RESTART"}}
                ]
            }
    

    Thanks!



  • @rts58 ok Looking at the read me it’s these at the end from my basic understanding

    ]
            }
        },
    


  • @rts58 so whole code should be

    module: 'MMM-ModuleScheduler',
            config: {
    	    // Show all modules at 9:15 every day and hide at 11:45
    	   global_schedule: {from: '15 9 * * *', to: '45 23 * * *'},
                notification_schedule: [
                    // TURN THE MONITOR/SCREEN ON AT 09:30 EVERY DAY
                    {notification:
     'REMOTE_ACTION', schedule: '30 9 * * *', payload: {action: "MONITORON"}},
                    // TURN THE MONITOR/SCREEN OFF AT 11:30pm EVERY DAY
                    {notification: 
    'REMOTE_ACTION', schedule: '30 23 * * *', payload: {action: "MONITOROFF"}},
                    // RESTART THE MAGICMIRROR PROCESS AT 2am EVERY SUNDAY
                    {notification: 
    'REMOTE_ACTION', schedule: '0 2 * * SUN', payload: {action: "RESTART"}}
                ]
            }
    },
    


  • @dazza120 Thanks, I did not have the “,” after the last “}” because it is the last module in the config. I thought the extra “,” would cause a config error. But it does not. Hopeful for success in the morning!



  • It still did not come on this morning ☹ . I just ran tail -130 ~/.pm2/logs/mm-out.log and found these results:

    MMM-ModuleScheduler is removing all scheduled jobs
    MMM-ModuleScheduler received CREATE_NOTIFICATION_SCHEDULE
    MMM-ModuleScheduler is scheduling REMOTE_ACTION using "30 9 * * *
    MMM-ModuleScheduler has scheduled REMOTE_ACTION
    MMM-ModuleScheduler will next send REMOTE_ACTION at Fri Jan 18 2019 09:30:00 GMT-0500 (EST)
    MMM-ModuleScheduler is scheduling REMOTE_ACTION using "30 23 * * *
    MMM-ModuleScheduler has scheduled REMOTE_ACTION
    MMM-ModuleScheduler will next send REMOTE_ACTION at Thu Jan 17 2019 23:30:00 GMT-0500 (EST)
    MMM-ModuleScheduler is scheduling REMOTE_ACTION using "0 2 * * SUN
    MMM-ModuleScheduler has scheduled REMOTE_ACTION
    MMM-ModuleScheduler will next send REMOTE_ACTION at Sun Jan 20 2019 02:00:00 GMT-0500 (EST)
    MMM-ModuleScheduler received CREATE_GLOBAL_SCHEDULE
    MMM-ModuleScheduler is creating a global schedule for all modules using "15 9 * * *" and "45 23 * * *" with dim level undefined
    MMM-ModuleScheduler has created the global schedule for all modules
    MMM-ModuleScheduler will next show all modules at Fri Jan 18 2019 09:15:00 GMT-0500 (EST)
    MMM-ModuleScheduler will next hide all modules at Thu Jan 17 2019 23:45:00 GMT-0500 (EST)
    

    Again later in the output I found:

    MMM-ModuleScheduler is sending SEND_NOTIFICATION to REMOTE_ACTION
    MMM-ModuleScheduler will next send SEND_NOTIFICATION to REMOTE_ACTION at Fri Jan 18 2019 23:30:00 GMT-0500 (EST) based on "30 23 * * *"
    Powering off HDMI
    
    
    MMM-ModuleScheduler is sending HIDE_MODULES to undefined
    MMM-ModuleScheduler will next send HIDE_MODULES to undefined at Fri Jan 18 2019 23:45:00 GMT-0500 (EST) based on "45 23 * * *"
    MMM-ModuleScheduler is sending SHOW_MODULES to undefined
    MMM-ModuleScheduler will next send SHOW_MODULES to undefined at Sat Jan 19 2019 09:15:00 GMT-0500 (EST) based on "15 9 * * *"
    MMM-ModuleScheduler is sending SEND_NOTIFICATION to REMOTE_ACTION
    MMM-ModuleScheduler will next send SEND_NOTIFICATION to REMOTE_ACTION at Sat Jan 19 2019 09:30:00 GMT-0500 (EST) based on "30 9 * * *"
    Powering on HDMI with preferred settings
    
    

    So it looks like the schedule works and it is trying to turn the monitor on, it just didn’t work. (Thanks @dazza120 I don’t think the schedule was working before.) This morning when the monitor didn’t come on per the schedule, I used the remote web page, it came on fine. How can I find out why the monitor did not come on with the schedule??



  • Re: MONITORON on does not work in schedule

    So for the last two days, this has been working correctly. I think it may be a combination of @dazza120 fix to my config, not messing with the pi for a full 2 days to let it fully run through it’s schedule, and removing openGL.