Absolute Beginner Needing Help Installing Dependencies



  • Hey, everyone.

    Hoping someone will be able to dive in and help me out. I’m really new to Raspberry Pi, and I’m pulling my hair out because I can’t get past this one last step. I’m running into issues trying to install MagicMirror. Here’s the command I’m using and the output I’m receiving. Any idea on how to fix this would be appreciated. I know practically nothing about how to code for Raspberry Pi, so very clear directions for what to try will be the most helpful. Thanks!

    pi@raspberrypi:~/MagicMirror $ bash -c "$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)"
    
    
    $$\      $$\                     $$\           $$\      $$\ $$\                                          $$$$$$\
    $$$\    $$$ |                    \__|          $$$\    $$$ |\__|                                        $$  __$$\
    $$$$\  $$$$ | $$$$$$\   $$$$$$\  $$\  $$$$$$$\ $$$$\  $$$$ |$$\  $$$$$$\   $$$$$$\   $$$$$$\   $$$$$$\  \__/  $$ |
    $$\$$\$$ $$ | \____$$\ $$  __$$\ $$ |$$  _____|$$\$$\$$ $$ |$$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  __$$\  $$$$$$  |
    $$ \$$$  $$ | $$$$$$$ |$$ /  $$ |$$ |$$ /      $$ \$$$  $$ |$$ |$$ |  \__|$$ |  \__|$$ /  $$ |$$ |  \__|$$  ____/
    $$ |\$  /$$ |$$  __$$ |$$ |  $$ |$$ |$$ |      $$ |\$  /$$ |$$ |$$ |      $$ |      $$ |  $$ |$$ |      $$ |
    $$ | \_/ $$ |\$$$$$$$ |\$$$$$$$ |$$ |\$$$$$$$\ $$ | \_/ $$ |$$ |$$ |      $$ |      \$$$$$$  |$$ |      $$$$$$$$\
    \__|     \__| \_______| \____$$ |\__| \_______|\__|     \__|\__|\__|      \__|       \______/ \__|      \________|
                           $$\   $$ |
                           \$$$$$$  |
                            \______/
    
    Updating packages ...
    Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
    Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
    Reading package lists... Done                 
    Installing helper tools ...
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    build-essential is already the newest version (12.3).
    curl is already the newest version (7.52.1-5+deb9u8).
    git is already the newest version (1:2.11.0-3+deb9u4).
    unzip is already the newest version (6.0-21).
    wget is already the newest version (1.18-5+deb9u2).
    The following package was automatically installed and is no longer required:
      realpath
    Use 'sudo apt autoremove' to remove it.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Check current Node installation ...
    Node currently installed. Checking version number.
    Minimum Node version: v5.1.0
    Installed Node version: v8.11.1
    No Node.js upgrade necessary.
    Cloning MagicMirror ...
    Cloning into 'MagicMirror'...
    remote: Enumerating objects: 302, done.
    remote: Counting objects: 100% (302/302), done.
    remote: Compressing objects: 100% (270/270), done.
    remote: Total 302 (delta 37), reused 170 (delta 22), pack-reused 0
    Receiving objects: 100% (302/302), 614.30 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (37/37), done.
    Cloning MagicMirror Done!
    Installing dependencies ...
    (node:31309) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
    npm WARN deprecated express-ipfilter@0.3.1: This package is no longer being maintained and contains security vulnerabilities
    npm WARN deprecated time-grunt@2.0.0: Deprecated because Grunt is practically unmaintained. Move on to something better. This package will continue to work with Grunt v1, but it will not receive any updates.
    npm ERR! Error: Method Not Allowed
    npm ERR!     at errorResponse (/usr/share/npm/lib/cache/add-named.js:260:10)
    npm ERR!     at /usr/share/npm/lib/cache/add-named.js:203:12
    npm ERR!     at saved (/usr/share/npm/node_modules/npm-registry-client/lib/get.js:167:7)
    npm ERR!     at FSReqWrap.oncomplete (fs.js:135:15)
    npm ERR! If you need help, you may report this *entire* log,
    npm ERR! including the npm and node versions, at:
    npm ERR!     
    
    npm ERR! System Linux 4.14.79-v7+
    npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v8.11.1
    npm ERR! npm -v 1.4.21
    npm ERR! code E405
    npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
    -
    > electron-chromedriver@1.8.0 install /home/pi/MagicMirror/node_modules/spectron/node_modules/electron-chromedriver
    > node ./download-chromedriver.js
    
    successfully dowloaded and extracted!
    npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
    npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    Unable to install dependencies!
    
    
    


  • Hello
    I meet the same issue.
    I have run the installation bash on a fresh newly setup raspberry pi 3 B.

    After this error, I tried to installa previous version of electron

    sudo npm install -g electron@1.7.6
    

    Error log is the same :

    (node:1853) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
    npm ERR! Error: Method Not Allowed
    npm ERR!     at errorResponse (/usr/share/npm/lib/cache/add-named.js:260:10)
    npm ERR!     at /usr/share/npm/lib/cache/add-named.js:203:12
    npm ERR!     at saved (/usr/share/npm/node_modules/npm-registry-client/lib/get.js:167:7)
    npm ERR!     at FSReqWrap.oncomplete (fs.js:135:15)
    npm ERR! If you need help, you may report this *entire* log,
    npm ERR! including the npm and node versions, at:
    npm ERR!     
    
    npm ERR! System Linux 4.14.79-v7+
    npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" "-g" "electron@1.7.6"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v8.11.1
    npm ERR! npm -v 1.4.21
    npm ERR! code E405
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    

    If you find some answer to this issue, I will be glad to setup my mirror.



  • @bhall321 HI! I see you are using the automatic installer which - I seem to recall - is missing Node. I would recommend doing a manual installation instead. The steps to do it is on GitHub and they are very easy to follow 🙂



  • hello mdhenriksen

    Thank you for your answer

    I have run the automatic installer and the first error I got was “npm Command unknown”

    So I installed Node and Npm and re-ran the automatic installer .
    Then I got this error.

    I am setting the sdcard for the raspberry Pi from scratch then i will try the manual step by step.

    Thank you
    Best regards

    Habib



  • @leroyhab Great! I think you will have more luck with that. Let me know how it goes!



  • @leroyhab said in Absolute Beginner Needing Help Installing Dependencies:

    npm -v 1.4.21

    npm is downlevel… mine is 6.6.0

    google search on upgrading npm…



  • Hello
    I am reading the step-by-step from github
    First thing missing is the installation of NPM
    Raspbian Stretch does not come with npm preinstalled (neither in normal, light or full version)

    Is there a recommended version of npm ?



  • @leroyhab whatever the latest is…

    this is a failing of the install script to check and install/update to the right levels

    execute

    sudo npm install npm@latest -g
    


  • Hello
    Wunderbar !!

    npm is installed with node !

    manual setup finished succesfully

    thank you very much



  • awesome!